summaryrefslogtreecommitdiff
path: root/dev-ruby/actionmailbox
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-ruby/actionmailbox
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-ruby/actionmailbox')
-rw-r--r--dev-ruby/actionmailbox/Manifest2
-rw-r--r--dev-ruby/actionmailbox/actionmailbox-6.0.3.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-ruby/actionmailbox/Manifest b/dev-ruby/actionmailbox/Manifest
index 9368e8e0c7d5..4e8d4daf0f17 100644
--- a/dev-ruby/actionmailbox/Manifest
+++ b/dev-ruby/actionmailbox/Manifest
@@ -1,3 +1,5 @@
DIST rails-6.0.2.2.tgz 18556125 BLAKE2B f4ed5cc6cbbfa84fb687aba5a6c8f2f6ab68febb41147c40ed8dbc6253c128adbac6503e65e89fe672f50270716d197d8c05b4e1e286aafd76581fc167e6c5da SHA512 c1aab2d6c72948c75a047aec9d9f651f0c1bae78bb17e2fa0cb393113ee1e59980dc093e6f3fd3b2f3839c9b3bb4afcd0b0badfd9574b35b932275a9d9800689
+DIST rails-6.0.3.tgz 18565682 BLAKE2B fe8601aec070535f487801eec16d944809be824e4833b7a906b47b4099dd5e72515ac3e492e4301dd651657fc2c4547ecbdd2c12265e04aad2758e9e284ad385 SHA512 f4572b4ebba9a79a6910c554f06e71efab5ccc0090e1a620e80b9d3b479cdd21d5a041437d90313e045e47ccc6e44eb21d4e56cc9fe1fb791cf5593427d0501b
EBUILD actionmailbox-6.0.2.2.ebuild 1660 BLAKE2B 481fcbe9c4d1819b18c5e27907839cc9e0f9d14010cd8bb11613e6f3acc4953703995e4786f58370349386810993d726d1b5f53c6ffcd8c703220759e3dc4b7f SHA512 3b6f884f4f7caf6fb8246bad4503bffe732ac4d1695cad7ceae978347a68b73df19a07bac0d745ea6ed015ac65c703c7f94dfcddcff99dac73991ba31fc11c43
+EBUILD actionmailbox-6.0.3.ebuild 1660 BLAKE2B 481fcbe9c4d1819b18c5e27907839cc9e0f9d14010cd8bb11613e6f3acc4953703995e4786f58370349386810993d726d1b5f53c6ffcd8c703220759e3dc4b7f SHA512 3b6f884f4f7caf6fb8246bad4503bffe732ac4d1695cad7ceae978347a68b73df19a07bac0d745ea6ed015ac65c703c7f94dfcddcff99dac73991ba31fc11c43
MISC metadata.xml 337 BLAKE2B f2b57aeb9ea63b3cba576df9bed58bc86577ddfb1707d3a183a8536c71c797aca25ca61b22eb50ea54368fac052518f889db0503b816767e05978c803e204351 SHA512 ad52f0a3bf101472aa80ce4b516349ac090620aba4afecde872585bf1ff11f55cffaf762df123910a16d70aaf67ef59dcbdec728816f611a2d5bde90d2b6d09f
diff --git a/dev-ruby/actionmailbox/actionmailbox-6.0.3.ebuild b/dev-ruby/actionmailbox/actionmailbox-6.0.3.ebuild
new file mode 100644
index 000000000000..bbdab69175ce
--- /dev/null
+++ b/dev-ruby/actionmailbox/actionmailbox-6.0.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="actionmailbox.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRAINSTALL="app config db"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/activejob-${PV}
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/activestorage-${PV}
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/mail-2.7.1:*
+"
+
+ruby_add_bdepend "test? (
+ dev-ruby/mocha
+)"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|sprockets\|stackprof\|websocket-client-simple\|libxml-ruby\|redis\|blade\|aws-sdk\|google-cloud\|azure-storage\|selenium\|webdrivers\|minitest-bisect\|minitest-retry\|minitest-reporters\|listen\|rack-cache\|capybara\)/ s:^:#:" \
+ -e '/:job/,/end/ s:^:#:' \
+ -e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
+ rm ../Gemfile.lock || die
+}
+
+each_ruby_prepare() {
+ sed -i -e 's:ruby:'${RUBY}':' test/dummy/bin/* || die
+}