summaryrefslogtreecommitdiff
path: root/dev-ruby/actionmailbox
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /dev-ruby/actionmailbox
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'dev-ruby/actionmailbox')
-rw-r--r--dev-ruby/actionmailbox/Manifest4
-rw-r--r--dev-ruby/actionmailbox/actionmailbox-6.0.3.5.ebuild54
-rw-r--r--dev-ruby/actionmailbox/actionmailbox-6.1.2.1.ebuild54
3 files changed, 112 insertions, 0 deletions
diff --git a/dev-ruby/actionmailbox/Manifest b/dev-ruby/actionmailbox/Manifest
index 41143e110141..5942d8f077f7 100644
--- a/dev-ruby/actionmailbox/Manifest
+++ b/dev-ruby/actionmailbox/Manifest
@@ -1,3 +1,7 @@
DIST rails-6.0.3.4.tgz 18568864 BLAKE2B 8f554a25ce02e4752c1a964257836a5cb0a6c01c3453ff11cd8423a9153e90ab833a32cadfe939a34e094cefd553f5514abd7817004b464b054889ab7dc05b76 SHA512 147f76792ce2d2484071fe247c8f1541c9ca27dcc405ff7a780771e3436a9acf3d326bbfd7c6dceca510b6f4d5209ee0a0859867174b8291d796ffd519fa2ba9
+DIST rails-6.0.3.5.tgz 18566999 BLAKE2B b07d1d6c1e2ebaaf3c337350bb08fe339e324818543dcd7163fe3c7ff56f50c5556f369badeb4fd48afa6d95449e18e57fa1b05db6ce544d38ee2f58bd3aa513 SHA512 c9d6bf689aeb40fb728fb681b65c48ebd51de893060ddac37a1fdefbb0d420cee3a456f148d96d577c651c9d7b994efdb3319fa865cb012af8712052a20a0bf3
+DIST rails-6.1.2.1.tgz 10990239 BLAKE2B ff1c9781eab32fda320cb2b9efc92e52ed155b659a43385781bfa422d03653879367bedc7ef4e3accb0a51b7962054eecd5202fd1e1a49ff7946c2f9388a69df SHA512 61e8bf0568c0b06a2c8f6c5e4ae6becc521646a5cdd3d6832c3b52998326a4bd437ad2bd284c010d445a3dc54bf519f7fbd2e9d4368c91b7d2a9abe46e3a276d
EBUILD actionmailbox-6.0.3.4.ebuild 1711 BLAKE2B 7675bfd3a16ecb41df77502335bf94672c2694b4371f5885b079f2e5b7a495966651586900cac98a47d05ce9986e39f4c58f45d02e4f288254e2503ada053465 SHA512 0d16c0130f6b9c86310d5315cd6b6670461440f1a03fdeb82004bcc87464fb76b8d07440396777702de13adce989d716a7b1fd189eedbb82d1fa0f4cfc0ffc48
+EBUILD actionmailbox-6.0.3.5.ebuild 1775 BLAKE2B 90207c1545b4bba3d5751f7441f10f25bcde49bfaf82fc7472f6ff836328095406a99fe6f4332cec9c9851f8942f368b7f703336a31a1b9c8e0428d483fd3e64 SHA512 3ae91c36cb621c167f3cb41a3058fc22d07fb868c90d143f542e397714b123032bfe1df01fc208c4bd260b336cb9919e4d5ec95d003963cb6a4c13e1c60c6b45
+EBUILD actionmailbox-6.1.2.1.ebuild 1765 BLAKE2B 253e473f0ebf088752e80e6dbfdd3b643dc0952e358ad45f5406ca37666890458c6f3d927aa2301219e66f9c17dd47f97f051999f65afe3c26daa81815a516d5 SHA512 9d43f5b9df90bad7292bd1293096ae4839c12e9e71212e6d1c83663f681281b3b91a45841611518c6b902a5f6e762a6d3830b1573a5065fb07b1b1b03aaec98b
MISC metadata.xml 337 BLAKE2B f2b57aeb9ea63b3cba576df9bed58bc86577ddfb1707d3a183a8536c71c797aca25ca61b22eb50ea54368fac052518f889db0503b816767e05978c803e204351 SHA512 ad52f0a3bf101472aa80ce4b516349ac090620aba4afecde872585bf1ff11f55cffaf762df123910a16d70aaf67ef59dcbdec728816f611a2d5bde90d2b6d09f
diff --git a/dev-ruby/actionmailbox/actionmailbox-6.0.3.5.ebuild b/dev-ruby/actionmailbox/actionmailbox-6.0.3.5.ebuild
new file mode 100644
index 000000000000..2f950375e6db
--- /dev/null
+++ b/dev-ruby/actionmailbox/actionmailbox-6.0.3.5.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="actionmailbox.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRAINSTALL="app config db"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/activejob-${PV}
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/activestorage-${PV}
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/mail-2.7.1:*
+"
+
+ruby_add_bdepend "test? (
+ dev-ruby/bundler
+ dev-ruby/mocha
+)"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|sprockets\|stackprof\|websocket-client-simple\|libxml-ruby\|redis\|blade\|aws-sdk\|google-cloud\|azure-storage\|selenium\|webdrivers\|minitest-bisect\|minitest-retry\|minitest-reporters\|listen\|rack-cache\|capybara\|webpacker\|bootsnap\|byebug\)/ s:^:#:" \
+ -e '/:job/,/end/ s:^:#:' \
+ -e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
+ rm ../Gemfile.lock || die
+ sed -i -e '/byebug/ s:^:#:' test/test_helper.rb || die
+}
+
+each_ruby_prepare() {
+ sed -i -e 's:ruby:'${RUBY}':' test/dummy/bin/* || die
+}
diff --git a/dev-ruby/actionmailbox/actionmailbox-6.1.2.1.ebuild b/dev-ruby/actionmailbox/actionmailbox-6.1.2.1.ebuild
new file mode 100644
index 000000000000..152595072405
--- /dev/null
+++ b/dev-ruby/actionmailbox/actionmailbox-6.1.2.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="actionmailbox.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRAINSTALL="app config db"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/activejob-${PV}
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/activestorage-${PV}
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/mail-2.7.1:*
+"
+
+ruby_add_bdepend "test? (
+ dev-ruby/bundler
+ dev-ruby/mocha
+)"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|mysql2\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|sprockets\|stackprof\|websocket-client-simple\|libxml-ruby\|redis\|blade\|aws-sdk\|google-cloud\|azure-storage\|selenium\|webdrivers\|minitest-bisect\|minitest-retry\|minitest-reporters\|listen\|rack-cache\|capybara\|webpacker\|bootsnap\)/ s:^:#:" \
+ -e '/group :\(doc\|job\|rubocop\|test\)/,/^end/ s:^:#:' \
+ -i ../Gemfile || die
+ rm ../Gemfile.lock || die
+ sed -i -e '/byebug/ s:^:#:' test/test_helper.rb || die
+}
+
+each_ruby_prepare() {
+ sed -i -e 's:ruby:'${RUBY}':' test/dummy/bin/* || die
+}