summaryrefslogtreecommitdiff
path: root/dev-ruby/acme-client/acme-client-2.0.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-03 20:56:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-03 20:56:28 +0100
commitfbda87924e6faa7a1919f1a2b4182490bde5ec5c (patch)
treef3114a4ed212a754756adce027aeef3a4a1a2e2a /dev-ruby/acme-client/acme-client-2.0.9.ebuild
parent3b08f674e3f771b49370edb144dab0958c8cf721 (diff)
gentoo resync : 03.09.2021
Diffstat (limited to 'dev-ruby/acme-client/acme-client-2.0.9.ebuild')
-rw-r--r--dev-ruby/acme-client/acme-client-2.0.9.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/acme-client/acme-client-2.0.9.ebuild b/dev-ruby/acme-client/acme-client-2.0.9.ebuild
new file mode 100644
index 000000000000..bffdd9ff1345
--- /dev/null
+++ b/dev-ruby/acme-client/acme-client-2.0.9.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_GEMSPEC="acme-client.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby client for the letsencrypt's ACME protocol."
+HOMEPAGE="https://github.com/unixcharles/acme-client"
+SRC_URI="https://github.com/unixcharles/acme-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend "|| ( dev-ruby/faraday:1 >=dev-ruby/faraday-0.17:0 )"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/vcr-2.9.3
+ >=dev-ruby/webmock-3.8:3
+)"
+
+all_ruby_prepare() {
+ # Avoid dependency on git
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}