summaryrefslogtreecommitdiff
path: root/dev-ruby/abstract/abstract-1.0.0-r5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
commit401101f9c8077911929d3f2b60a37098460a5d89 (patch)
treec2bef4719f6787550f0916aeaa8f4f403a9296af /dev-ruby/abstract/abstract-1.0.0-r5.ebuild
parent4cbcc855382a06088e2f016f62cafdbcb7e40665 (diff)
gentoo resync : 25.03.2022
Diffstat (limited to 'dev-ruby/abstract/abstract-1.0.0-r5.ebuild')
-rw-r--r--dev-ruby/abstract/abstract-1.0.0-r5.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ruby/abstract/abstract-1.0.0-r5.ebuild b/dev-ruby/abstract/abstract-1.0.0-r5.ebuild
new file mode 100644
index 000000000000..1febb53a86ce
--- /dev/null
+++ b/dev-ruby/abstract/abstract-1.0.0-r5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library which enable you to define abstract method in Ruby"
+HOMEPAGE="https://rubygems.org/gems/abstract"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/test.rb || die "tests failed"
+}