summaryrefslogtreecommitdiff
path: root/dev-ros/xacro/xacro-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-ros/xacro/xacro-9999.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-ros/xacro/xacro-9999.ebuild')
-rw-r--r--dev-ros/xacro/xacro-9999.ebuild17
1 files changed, 14 insertions, 3 deletions
diff --git a/dev-ros/xacro/xacro-9999.ebuild b/dev-ros/xacro/xacro-9999.ebuild
index e29730c0f573..8383de0334c5 100644
--- a/dev-ros/xacro/xacro-9999.ebuild
+++ b/dev-ros/xacro/xacro-9999.ebuild
@@ -13,9 +13,20 @@ LICENSE="BSD"
SLOT="0"
IUSE=""
-RDEPEND="dev-ros/roslint[${PYTHON_USEDEP}]"
+RDEPEND="dev-ros/roslint[${PYTHON_SINGLE_USEDEP}]"
DEPEND="${RDEPEND}
- test? ( dev-ros/rostest[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )
+ test? (
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ )
"
RDEPEND="${RDEPEND}
- dev-ros/roslaunch[${PYTHON_USEDEP}]"
+ dev-ros/roslaunch[${PYTHON_SINGLE_USEDEP}]"
+PATCHES=( "${FILESDIR}/tests.patch" )
+
+src_test() {
+ local sd="$(python_get_sitedir)"
+ local local_sd="${BUILD_DIR}/devel/${sd#${EPREFIX}/usr}"
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ PYTHONPATH="${local_sd}:${PYTHONPATH}" ros-catkin_src_test
+}