summaryrefslogtreecommitdiff
path: root/dev-ros/uuid_msgs/uuid_msgs-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ros/uuid_msgs/uuid_msgs-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ros/uuid_msgs/uuid_msgs-9999.ebuild')
-rw-r--r--dev-ros/uuid_msgs/uuid_msgs-9999.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ros/uuid_msgs/uuid_msgs-9999.ebuild b/dev-ros/uuid_msgs/uuid_msgs-9999.ebuild
new file mode 100644
index 000000000000..2536e3890222
--- /dev/null
+++ b/dev-ros/uuid_msgs/uuid_msgs-9999.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros-geographic-info/unique_identifier"
+VER_PREFIX=unique_identifier-
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="ROS messages for universally unique identifiers"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"