summaryrefslogtreecommitdiff
path: root/dev-ros/unique_id
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ros/unique_id
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ros/unique_id')
-rw-r--r--dev-ros/unique_id/Manifest5
-rw-r--r--dev-ros/unique_id/metadata.xml11
-rw-r--r--dev-ros/unique_id/unique_id-1.0.6.ebuild24
-rw-r--r--dev-ros/unique_id/unique_id-9999.ebuild24
4 files changed, 64 insertions, 0 deletions
diff --git a/dev-ros/unique_id/Manifest b/dev-ros/unique_id/Manifest
new file mode 100644
index 000000000000..f085e93f690f
--- /dev/null
+++ b/dev-ros/unique_id/Manifest
@@ -0,0 +1,5 @@
+DIST unique_identifier-1.0.6.tar.gz 12305 SHA256 e376df28058d69da4c3c5fce4ef5d3cc24518ed9b64a181055ff86a2fc11b832 SHA512 d81409786a311fd1d23937fd24bf0365920f6b9cd7b4ba9803935844c0dab0a1765b2790f88673fe8fffea70ff13161ddadc7644bc8d39e3f0c255007b267156 WHIRLPOOL 5242ebcaf5c5cf8b6f16cfd9e1b09936f8af646d3ea629d856387759ccece0f69bc87e6abfc34ba48c199b266ca08bee960fee46dc4adb890ce952fb401c524c
+EBUILD unique_id-1.0.6.ebuild 640 SHA256 b47501e1a8583ef6aa3ecb8b65624975259e84ca99f689ea63a56374d5bdb30d SHA512 fe9738d1bdca52e53e4318d58494a76e396c71c6d8ed04e3a771019aae9ee4b37ed9f9156803d071c33f0202fbb4d17968854dcc79e9d66ed4756858a527e105 WHIRLPOOL 15a6765c74b80f842382352e8f572609d45d16af83ba419ac21b32b5e4d793e1a274dc87c6266f303c3b4fcb2a258b91315ebf9d54d53ed89dd85b28874f175a
+EBUILD unique_id-9999.ebuild 640 SHA256 8bc64c95aafff89b1cec72b32ad17bad3c26402a6f76efde61de5f540dc23658 SHA512 9c0f58bae2abd15cb8d54a15a772e4d4e707cadad24ac4aea56ded51860dbaeb2ea99c0213f8692e737225934ad9858daf278f3c99a890f24a2f937e0e3dfaa8 WHIRLPOOL 41567eca77e8a443af69d87a590af3adc7992fca69a67997d57cab0d1df527b7df5ad3397b6b01aa5bc292151932b53fefeeb57d93204bb6b7318f03f2e24fc6
+MISC ChangeLog 1287 SHA256 703dc40f2a8e70feb4b8f1fb5de555bd9b71d2b2c071170d6f99ba285b918412 SHA512 5fc524b623a4f64ee8e0c16f00c0e5fcc8068db7fe5fff8a5a9ed45b20ade97d08197702d4d0ca7a41d9bc5dcd107068aa737011051295b047e6e9aae7cf0d19 WHIRLPOOL 85489ac3c30d3637439510230c196af4ceda1f371f876fef8a8d94c96dec0e12dbb6f55f9d336d3e321b25c6f909c7146ac25a7acc4f913c8c214a6508e69efa
+MISC metadata.xml 351 SHA256 03ea4af366a006f80a6b2dd6cfac0508aabea23fbf4dcdf7f5f3222ed0292749 SHA512 8636c13070578878bd780ee448a76c3a5040758e23f5c1e990bd433fdf91a3645294210d172917317715f806d87dac379a023979a555c68270e0c79319c4b659 WHIRLPOOL 86968a7bb49ccd179c58bc2d19ca7ada196f229f78e412acbe2bcae55ebdd88549e32d7fe3ea9af1e46112b1bf3cef382d49bf73941028f8e4c1697f966966b6
diff --git a/dev-ros/unique_id/metadata.xml b/dev-ros/unique_id/metadata.xml
new file mode 100644
index 000000000000..07abf56c1b23
--- /dev/null
+++ b/dev-ros/unique_id/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros-geographic-info/unique_identifier</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/unique_id/unique_id-1.0.6.ebuild b/dev-ros/unique_id/unique_id-1.0.6.ebuild
new file mode 100644
index 000000000000..612f302dfc98
--- /dev/null
+++ b/dev-ros/unique_id/unique_id-1.0.6.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-geographic-info/unique_identifier"
+VER_PREFIX=unique_identifier-
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS Python and C++ interfaces for universally unique identifiers"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/uuid_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/roscpp
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest dev-python/nose[${PYTHON_USEDEP}] )"
diff --git a/dev-ros/unique_id/unique_id-9999.ebuild b/dev-ros/unique_id/unique_id-9999.ebuild
new file mode 100644
index 000000000000..c67faa3ad095
--- /dev/null
+++ b/dev-ros/unique_id/unique_id-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-geographic-info/unique_identifier"
+VER_PREFIX=unique_identifier-
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS Python and C++ interfaces for universally unique identifiers"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/uuid_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/roscpp
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest dev-python/nose[${PYTHON_USEDEP}] )"