summaryrefslogtreecommitdiff
path: root/dev-ros/unique_id
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-ros/unique_id
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-ros/unique_id')
-rw-r--r--dev-ros/unique_id/Manifest5
-rw-r--r--dev-ros/unique_id/files/tests.patch17
-rw-r--r--dev-ros/unique_id/unique_id-1.0.6.ebuild14
-rw-r--r--dev-ros/unique_id/unique_id-9999.ebuild14
4 files changed, 44 insertions, 6 deletions
diff --git a/dev-ros/unique_id/Manifest b/dev-ros/unique_id/Manifest
index 3db24bef13fe..6c4d11eb682f 100644
--- a/dev-ros/unique_id/Manifest
+++ b/dev-ros/unique_id/Manifest
@@ -1,4 +1,5 @@
+AUX tests.patch 644 BLAKE2B bbe5ff5cc6e7a514475500e3460f438db5eaeefa84f2c0569561e396eb9f04644c2380668a1ca7c317c0f28db9d5b47fcaa283362d1f0fb3fd1b1cdc6770102f SHA512 fbcb1a7a515a3832b3d86e045953e3809811daddb83bdbed7eaf7528ce5afd148f0fbfc5cb4aea458ac5e8852ef9dcdf614128d04523c5a6f73a9a9538640a53
DIST unique_identifier-1.0.6.tar.gz 12305 BLAKE2B 3aa8ba6a7386588f56546e42efd61cc52a6a7c44444462c55f26830e162eafbc49a7aaca2315d965d75f8f0151467147af7db8a0fbe96def66c33e81371e069c SHA512 d81409786a311fd1d23937fd24bf0365920f6b9cd7b4ba9803935844c0dab0a1765b2790f88673fe8fffea70ff13161ddadc7644bc8d39e3f0c255007b267156
-EBUILD unique_id-1.0.6.ebuild 629 BLAKE2B d4e7c7b69db49694e441e0a1ec99c88a2afaa3250606bfa5925e9aea88db5ce106fa1d5e24741dc11f88481adc333e7cb018eb0706f51ad36fc0596a6dada8f9 SHA512 4552ecd62998f8cd074c0c91326d26112cb8a469d3a4f042586c807e0904055aa18b615bbf5f5936056ec8e7f7874ab8b01dba3dafae0a139ff125148146c2c7
-EBUILD unique_id-9999.ebuild 629 BLAKE2B d4e7c7b69db49694e441e0a1ec99c88a2afaa3250606bfa5925e9aea88db5ce106fa1d5e24741dc11f88481adc333e7cb018eb0706f51ad36fc0596a6dada8f9 SHA512 4552ecd62998f8cd074c0c91326d26112cb8a469d3a4f042586c807e0904055aa18b615bbf5f5936056ec8e7f7874ab8b01dba3dafae0a139ff125148146c2c7
+EBUILD unique_id-1.0.6.ebuild 944 BLAKE2B a60ff413935866b3054b3ee9bcb07f3b0b37a3490ac6720a4cf1b8a45fb824560b3a910f2791799a9b2504022f89039513de0d6d8bde8aa342729f6d70225d5f SHA512 94e7630018ebafd9a4ce68b0f365e92169d8929b052dfc11e56a6598f530cf0c06dc0ad5d9798d7f62a27b283009af4aec887c4a8f789923ffa2568c6c1af020
+EBUILD unique_id-9999.ebuild 944 BLAKE2B a60ff413935866b3054b3ee9bcb07f3b0b37a3490ac6720a4cf1b8a45fb824560b3a910f2791799a9b2504022f89039513de0d6d8bde8aa342729f6d70225d5f SHA512 94e7630018ebafd9a4ce68b0f365e92169d8929b052dfc11e56a6598f530cf0c06dc0ad5d9798d7f62a27b283009af4aec887c4a8f789923ffa2568c6c1af020
MISC metadata.xml 351 BLAKE2B 263bd97d8a235f46caee579594b8c44e0f638ba246459a9b7090da4fafdbafcc26a8fca2716c005a2cfb4dac98def55e691744d7ce869528032652b2f7fda96e SHA512 8636c13070578878bd780ee448a76c3a5040758e23f5c1e990bd433fdf91a3645294210d172917317715f806d87dac379a023979a555c68270e0c79319c4b659
diff --git a/dev-ros/unique_id/files/tests.patch b/dev-ros/unique_id/files/tests.patch
new file mode 100644
index 000000000000..b64a1be5e38b
--- /dev/null
+++ b/dev-ros/unique_id/files/tests.patch
@@ -0,0 +1,17 @@
+Index: unique_id/tests/test_unique_id.py
+===================================================================
+--- unique_id.orig/tests/test_unique_id.py
++++ unique_id/tests/test_unique_id.py
+@@ -20,10 +20,10 @@ class TestPythonUUID(unittest.TestCase):
+ def test_random_uuids(self):
+ N = 1000
+ uu = []
+- for i in xrange(N):
++ for i in range(N):
+ uu.append(fromRandom())
+ self.assertEqual(type(uu[i]), uuid.UUID)
+- for j in xrange(i-1, -1, -1):
++ for j in range(i-1, -1, -1):
+ self.assertNotEqual(uu[i], uu[j])
+
+ # UUID generation from URL tests
diff --git a/dev-ros/unique_id/unique_id-1.0.6.ebuild b/dev-ros/unique_id/unique_id-1.0.6.ebuild
index 7ff69d0fac63..32432dfa5632 100644
--- a/dev-ros/unique_id/unique_id-1.0.6.ebuild
+++ b/dev-ros/unique_id/unique_id-1.0.6.ebuild
@@ -16,9 +16,19 @@ IUSE=""
RDEPEND="
dev-ros/uuid_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
dev-ros/roscpp
"
DEPEND="${RDEPEND}
dev-ros/uuid_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- test? ( dev-cpp/gtest dev-python/nose[${PYTHON_USEDEP}] )"
+ test? (
+ dev-cpp/gtest
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ )"
+PATCHES=( "${FILESDIR}/tests.patch" )
+
+src_test() {
+ # Those tests fail and are commented as undefined behavior in the code
+ export GTEST_FILTER='-BoostUUID.fromUrnString:BoostUUID.fromTooLongString:BoostUUID2.fromUrnString:BoostUUID2.fromTooLongString'
+ ros-catkin_src_test
+}
diff --git a/dev-ros/unique_id/unique_id-9999.ebuild b/dev-ros/unique_id/unique_id-9999.ebuild
index 7ff69d0fac63..32432dfa5632 100644
--- a/dev-ros/unique_id/unique_id-9999.ebuild
+++ b/dev-ros/unique_id/unique_id-9999.ebuild
@@ -16,9 +16,19 @@ IUSE=""
RDEPEND="
dev-ros/uuid_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
dev-ros/roscpp
"
DEPEND="${RDEPEND}
dev-ros/uuid_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- test? ( dev-cpp/gtest dev-python/nose[${PYTHON_USEDEP}] )"
+ test? (
+ dev-cpp/gtest
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ )"
+PATCHES=( "${FILESDIR}/tests.patch" )
+
+src_test() {
+ # Those tests fail and are commented as undefined behavior in the code
+ export GTEST_FILTER='-BoostUUID.fromUrnString:BoostUUID.fromTooLongString:BoostUUID2.fromUrnString:BoostUUID2.fromTooLongString'
+ ros-catkin_src_test
+}