summaryrefslogtreecommitdiff
path: root/dev-ros/tf2_ros
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/tf2_ros
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/tf2_ros')
-rw-r--r--dev-ros/tf2_ros/Manifest6
-rw-r--r--dev-ros/tf2_ros/metadata.xml11
-rw-r--r--dev-ros/tf2_ros/tf2_ros-0.6.1.ebuild31
-rw-r--r--dev-ros/tf2_ros/tf2_ros-0.6.2.ebuild31
-rw-r--r--dev-ros/tf2_ros/tf2_ros-9999.ebuild31
5 files changed, 110 insertions, 0 deletions
diff --git a/dev-ros/tf2_ros/Manifest b/dev-ros/tf2_ros/Manifest
new file mode 100644
index 000000000000..e38a70699f51
--- /dev/null
+++ b/dev-ros/tf2_ros/Manifest
@@ -0,0 +1,6 @@
+DIST geometry2-0.6.1.tar.gz 162912 BLAKE2B 103937894921111da2058f61b555cb9498ea053e8c8dac357383fc326e214bf88e74a65c97021cf7dd0ecb2b5a38606c3ad3660e365af145349c764660c56726 SHA512 392719295eedf4a5f580390f076a14f9909f49681223d8c50ccb88d57b784c1e50383d28ff10bddc21424662f261504c29525c24965a51462d6e9e62d702d6ef
+DIST geometry2-0.6.2.tar.gz 166807 BLAKE2B 821ad4bc68ff2703df53d3d85505cd892f0399abe99b7fbff13852bda0895e8b28bc4e6aaff0590d4bc7124d36c396e7c477be0a9d56c532fe491099ccb3990d SHA512 fddf5e114600a2814bfecc71c52ddc820fa113fbd07584cd43d4b8a5eb395e9d9b1f78e28c193866920690edb8a5b220bfed949a6e6741926dcea1fc654edadf
+EBUILD tf2_ros-0.6.1.ebuild 863 BLAKE2B de1be6947d42661a1e4826884c1c4f9ebddbe0c506fc91e1cb40c2ff05d3c4a19265b6af56dc95258404cf3ad5a25607eaa5fe2515836870dc85bed771735986 SHA512 1f01d037cc92884ed61b4b15a9911e2d9a68152267612ebf7fc3785b89d2e6b738fa7f439c40bc59a071d859b638ed7e7e5b1e8e22b47d804fcbe1b7c76cc3bf
+EBUILD tf2_ros-0.6.2.ebuild 863 BLAKE2B de1be6947d42661a1e4826884c1c4f9ebddbe0c506fc91e1cb40c2ff05d3c4a19265b6af56dc95258404cf3ad5a25607eaa5fe2515836870dc85bed771735986 SHA512 1f01d037cc92884ed61b4b15a9911e2d9a68152267612ebf7fc3785b89d2e6b738fa7f439c40bc59a071d859b638ed7e7e5b1e8e22b47d804fcbe1b7c76cc3bf
+EBUILD tf2_ros-9999.ebuild 863 BLAKE2B f456a8e3f159c2271d35970cc06c08880fc45d321b4bd35a1926102d008af02762fc1024ab0aa453150975634ea74d3bca4714ffdf5f09c2663be11ea6b0ddd2 SHA512 900d622cad352217d1a3211ed32a2002db47c032dfa8552a2c524e06de9c31ae8bd59c899285ad4e18ef656bb6afee11c1f583006a5ffa220f1657d3905906a4
+MISC metadata.xml 327 BLAKE2B ee9a902001f4ab56d6bdca309315ae772642fcd9c231dbbbad1ee532424d3e4dfd8140be540816f24ae5cecb06746d8258259d5e22d4cb70d7dbc6b803c8f97a SHA512 12555186ce2fbe547f8e8fc19483accf1fb7821bc1c4f1bdf3fb16855a801ed07849d5d86cf07aba1f6d4238121591355a27a50bde0e27efd04ef589c62176da
diff --git a/dev-ros/tf2_ros/metadata.xml b/dev-ros/tf2_ros/metadata.xml
new file mode 100644
index 000000000000..03f74b7656e7
--- /dev/null
+++ b/dev-ros/tf2_ros/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros/geometry2</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/tf2_ros/tf2_ros-0.6.1.ebuild b/dev-ros/tf2_ros/tf2_ros-0.6.1.ebuild
new file mode 100644
index 000000000000..0e85b91f5107
--- /dev/null
+++ b/dev-ros/tf2_ros/tf2_ros-0.6.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/geometry2"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="ROS bindings for the tf2 library, for both Python and C++"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/actionlib[${PYTHON_USEDEP}]
+ dev-ros/message_filters
+ dev-ros/roscpp
+ dev-ros/rosgraph
+ dev-libs/boost:=[threads]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_py[${PYTHON_USEDEP}]
+ dev-ros/actionlib_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"
diff --git a/dev-ros/tf2_ros/tf2_ros-0.6.2.ebuild b/dev-ros/tf2_ros/tf2_ros-0.6.2.ebuild
new file mode 100644
index 000000000000..0e85b91f5107
--- /dev/null
+++ b/dev-ros/tf2_ros/tf2_ros-0.6.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/geometry2"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="ROS bindings for the tf2 library, for both Python and C++"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/actionlib[${PYTHON_USEDEP}]
+ dev-ros/message_filters
+ dev-ros/roscpp
+ dev-ros/rosgraph
+ dev-libs/boost:=[threads]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_py[${PYTHON_USEDEP}]
+ dev-ros/actionlib_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"
diff --git a/dev-ros/tf2_ros/tf2_ros-9999.ebuild b/dev-ros/tf2_ros/tf2_ros-9999.ebuild
new file mode 100644
index 000000000000..00234a1ad22c
--- /dev/null
+++ b/dev-ros/tf2_ros/tf2_ros-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/geometry2"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="ROS bindings for the tf2 library, for both Python and C++"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/actionlib[${PYTHON_USEDEP}]
+ dev-ros/message_filters
+ dev-ros/roscpp
+ dev-ros/rosgraph
+ dev-libs/boost:=[threads]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_py[${PYTHON_USEDEP}]
+ dev-ros/actionlib_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"