summaryrefslogtreecommitdiff
path: root/dev-ros/tf2_py
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/tf2_py
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/tf2_py')
-rw-r--r--dev-ros/tf2_py/Manifest6
-rw-r--r--dev-ros/tf2_py/metadata.xml11
-rw-r--r--dev-ros/tf2_py/tf2_py-0.6.1.ebuild22
-rw-r--r--dev-ros/tf2_py/tf2_py-0.6.2.ebuild22
-rw-r--r--dev-ros/tf2_py/tf2_py-9999.ebuild22
5 files changed, 83 insertions, 0 deletions
diff --git a/dev-ros/tf2_py/Manifest b/dev-ros/tf2_py/Manifest
new file mode 100644
index 000000000000..4bf300477052
--- /dev/null
+++ b/dev-ros/tf2_py/Manifest
@@ -0,0 +1,6 @@
+DIST geometry2-0.6.1.tar.gz 162912 BLAKE2B 103937894921111da2058f61b555cb9498ea053e8c8dac357383fc326e214bf88e74a65c97021cf7dd0ecb2b5a38606c3ad3660e365af145349c764660c56726 SHA512 392719295eedf4a5f580390f076a14f9909f49681223d8c50ccb88d57b784c1e50383d28ff10bddc21424662f261504c29525c24965a51462d6e9e62d702d6ef
+DIST geometry2-0.6.2.tar.gz 166807 BLAKE2B 821ad4bc68ff2703df53d3d85505cd892f0399abe99b7fbff13852bda0895e8b28bc4e6aaff0590d4bc7124d36c396e7c477be0a9d56c532fe491099ccb3990d SHA512 fddf5e114600a2814bfecc71c52ddc820fa113fbd07584cd43d4b8a5eb395e9d9b1f78e28c193866920690edb8a5b220bfed949a6e6741926dcea1fc654edadf
+EBUILD tf2_py-0.6.1.ebuild 414 BLAKE2B 93348fc5981f8d1947882242610ec34835c9fbc57e63db147d63e627311dd2a59463ad86734eb59d63ca568dcd0e47914a4b6628becf8fe03781e2bca28a6a05 SHA512 2d5d8540591e564816d98296a01eac4708e1ac3c1d5da370ca70b1f752304ed71019a3fba704db3729e8628d710b76d558f1b345f2bfd718f722def2b94a5036
+EBUILD tf2_py-0.6.2.ebuild 414 BLAKE2B 93348fc5981f8d1947882242610ec34835c9fbc57e63db147d63e627311dd2a59463ad86734eb59d63ca568dcd0e47914a4b6628becf8fe03781e2bca28a6a05 SHA512 2d5d8540591e564816d98296a01eac4708e1ac3c1d5da370ca70b1f752304ed71019a3fba704db3729e8628d710b76d558f1b345f2bfd718f722def2b94a5036
+EBUILD tf2_py-9999.ebuild 414 BLAKE2B ddfb7630d561add62cb401b565df834d0d9d824f64dc099aa4963aa92381c332b05f2766b8546d7f649175bcd3ae63ef40e4754b10493055cd722dc7cb97e678 SHA512 3ee385b68f0a48c25e018f179447ea8b8c747c7e6a144280d2ed373f542754325c3ae8de791df6c91cf9e2a1ace19a5a74397fe2fb65d1bb67b3ae00f6c97c5c
+MISC metadata.xml 327 BLAKE2B ee9a902001f4ab56d6bdca309315ae772642fcd9c231dbbbad1ee532424d3e4dfd8140be540816f24ae5cecb06746d8258259d5e22d4cb70d7dbc6b803c8f97a SHA512 12555186ce2fbe547f8e8fc19483accf1fb7821bc1c4f1bdf3fb16855a801ed07849d5d86cf07aba1f6d4238121591355a27a50bde0e27efd04ef589c62176da
diff --git a/dev-ros/tf2_py/metadata.xml b/dev-ros/tf2_py/metadata.xml
new file mode 100644
index 000000000000..03f74b7656e7
--- /dev/null
+++ b/dev-ros/tf2_py/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros/geometry2</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/tf2_py/tf2_py-0.6.1.ebuild b/dev-ros/tf2_py/tf2_py-0.6.1.ebuild
new file mode 100644
index 000000000000..97b18592a9a3
--- /dev/null
+++ b/dev-ros/tf2_py/tf2_py-0.6.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/geometry2"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="TF2 python bindings"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/tf2
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/tf2_py/tf2_py-0.6.2.ebuild b/dev-ros/tf2_py/tf2_py-0.6.2.ebuild
new file mode 100644
index 000000000000..97b18592a9a3
--- /dev/null
+++ b/dev-ros/tf2_py/tf2_py-0.6.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/geometry2"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="TF2 python bindings"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/tf2
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/tf2_py/tf2_py-9999.ebuild b/dev-ros/tf2_py/tf2_py-9999.ebuild
new file mode 100644
index 000000000000..8228f47ca0ba
--- /dev/null
+++ b/dev-ros/tf2_py/tf2_py-9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/geometry2"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="TF2 python bindings"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/tf2
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"