summaryrefslogtreecommitdiff
path: root/dev-ros/tf/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-ros/tf/files
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-ros/tf/files')
-rw-r--r--dev-ros/tf/files/boost.patch28
-rw-r--r--dev-ros/tf/files/yaml.patch13
2 files changed, 13 insertions, 28 deletions
diff --git a/dev-ros/tf/files/boost.patch b/dev-ros/tf/files/boost.patch
deleted file mode 100644
index dd926cf05848..000000000000
--- a/dev-ros/tf/files/boost.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 2eed72cb7b63fc4ee98af695c625d9a741a09897 Mon Sep 17 00:00:00 2001
-From: Maarten de Vries <maarten@de-vri.es>
-Date: Thu, 17 Jan 2019 21:40:28 +0100
-Subject: [PATCH] Remove `signals` from find_package(Boost COMPONENTS ...)
-
-tf is using signals2, which is not the same library as signals.
-Additionally, signals2 has always been header only, and header only
-libraries must not be listed in find_package.
-
-Boost 1.69 removed the old signals library entirely, so the otherwise
-useless `COMPONENTS signals` actually breaks the build.
----
- tf/CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/tf/CMakeLists.txt b/tf/CMakeLists.txt
-index 04dcb4e8..b469f658 100644
---- a/tf/CMakeLists.txt
-+++ b/tf/CMakeLists.txt
-@@ -15,7 +15,7 @@ find_package(catkin REQUIRED COMPONENTS
- std_msgs
- tf2_ros
- )
--find_package(Boost REQUIRED COMPONENTS thread signals system)
-+find_package(Boost REQUIRED COMPONENTS thread system)
-
- catkin_python_setup()
-
diff --git a/dev-ros/tf/files/yaml.patch b/dev-ros/tf/files/yaml.patch
new file mode 100644
index 000000000000..344ef80417ae
--- /dev/null
+++ b/dev-ros/tf/files/yaml.patch
@@ -0,0 +1,13 @@
+Index: tf/src/tf/listener.py
+===================================================================
+--- tf.orig/src/tf/listener.py
++++ tf/src/tf/listener.py
+@@ -94,7 +94,7 @@ class Transformer(object):
+
+ def getFrameStrings(self):
+ """ Not a recommended API, only here for backwards compatibility """
+- data = yaml.load(self._buffer.all_frames_as_yaml()) or {}
++ data = yaml.safe_load(self._buffer.all_frames_as_yaml()) or {}
+ return [p for p, _ in data.items()]
+
+ def getLatestCommonTime(self, source_frame, dest_frame):