summaryrefslogtreecommitdiff
path: root/dev-ros/test_tf2/test_tf2-0.7.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-ros/test_tf2/test_tf2-0.7.5.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-ros/test_tf2/test_tf2-0.7.5.ebuild')
-rw-r--r--dev-ros/test_tf2/test_tf2-0.7.5.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ros/test_tf2/test_tf2-0.7.5.ebuild b/dev-ros/test_tf2/test_tf2-0.7.5.ebuild
new file mode 100644
index 000000000000..24179b340482
--- /dev/null
+++ b/dev-ros/test_tf2/test_tf2-0.7.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros/geometry2"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="TF2 unit tests"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/tf
+ dev-ros/tf2
+ dev-ros/tf2_bullet
+ dev-ros/tf2_ros[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/tf2_geometry_msgs[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/tf2_kdl[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/tf2_msgs
+ dev-ros/rosbash
+ sci-libs/orocos_kdl
+ $(python_gen_cond_dep "dev-python/python_orocos_kdl[\${PYTHON_USEDEP}]")
+ dev-libs/boost:=[threads]
+ dev-cpp/gtest
+"
+
+mycatkincmakeargs=( "-DCATKIN_ENABLE_TESTING=ON" )