summaryrefslogtreecommitdiff
path: root/dev-ros/test_rosservice
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-ros/test_rosservice
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-ros/test_rosservice')
-rw-r--r--dev-ros/test_rosservice/Manifest2
-rw-r--r--dev-ros/test_rosservice/test_rosservice-1.15.4.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-ros/test_rosservice/Manifest b/dev-ros/test_rosservice/Manifest
index 0b574b9acc4e..6c1171139730 100644
--- a/dev-ros/test_rosservice/Manifest
+++ b/dev-ros/test_rosservice/Manifest
@@ -1,5 +1,7 @@
AUX yaml.patch 2877 BLAKE2B af708d68c805323af1e337789798c0318f49e7805cc3b6a52a895edff40fcb71a48c467c2e009c04f19e5ad75231f07e60d94cbfe2baa7a47a5d3d4cd78bd379 SHA512 cd3099ed89f475603151e290dbdddcc170bad5a01002ce51e5a44ceed0ab864480e8daf1eaaf3ab5fbf4fec550f6a0e91ec7dc6400b2fb227abc2bdadc3d64b2
DIST ros_comm-1.14.3.tar.gz 1045287 BLAKE2B c079983aa730e70028d1bf2c365d01d99ce09ced0c0f6443b18f9d0fb83715f6af4b313d6db4eb99dcc10052c81fa3e6560e7b3591b2fbe14b9ec20fac24babe SHA512 52df24f10f476697ee6fa340da354b45431f35018a25e2674dc9306f175929a4b0368753503ea143f87aeb4945a2e67c37f83d833f54b53f9a76a81022c280a3
+DIST ros_comm-1.15.4.tar.gz 1071246 BLAKE2B 57867c192bfd48f3a0534762808c668031081a6155510879e68f9618226b9c5eff0d5fc9ec0e7ec8d0cc1f0d74794a4e55151036275ae6fc5bb613cc42137ddc SHA512 f92233cbf5ee97832023545730d3e756dfa08507072c074ac3e0763db1c2c2ab9fcbb0c90995a0c5d43f0ddc2ee528c185173a664b19abe4f8159aa3f3cb20dc
EBUILD test_rosservice-1.14.3-r1.ebuild 713 BLAKE2B faacb0d4583af8cde634e608012ed3d1d89a0cd912a54f3c8931a109d3e2ab06965c85c123e7bd92cc83a1a86bc222e5f6648e079dc9e2644ae19268bf96d2b5 SHA512 8604ba792e6a01dc7f085061889d278d48474da3ad21a2580f560ba771dafb3041afd2fe9a797c886bc01af8f04c7f4108f0c8387c25501d5ef3d1667813373a
+EBUILD test_rosservice-1.15.4.ebuild 676 BLAKE2B ecff62b277ac96c0c94754d50a0b1640eebba549a86661f69aebf693ec39d5f66114a7f366ce1adeced5523aa3ffcb7b5d2a4d60fc7e6232f5b8dffa69680e73 SHA512 71453f94f88b1055698f09b4688ad25b5b61246eac009b7a7abed9f13ded12ab158029b16ec76e1900dd2dd8591744db95bdb40d54a20296a01cd04cf0b38f3a
EBUILD test_rosservice-9999.ebuild 679 BLAKE2B d8c7decce6abc14a7e9c0d9b36a40a001c282333d0e50e8caf7c8598b646adb458bce1aadd01a2a97639dac10d2ec7a232f8145c6fb6a904eb83311bbb47afae SHA512 36c5673453deb431ee1e5816af18510e7bfd9d324089e6bf05af963ef4d769ddc2d8d1d04796f849b75a8d0aeb0dc9663fa9747c07ad20c68934e258e0d273cc
MISC metadata.xml 326 BLAKE2B c8975866f4616482c71ac67084df89cea2643cc8233957c86450f7dba2ce320448e4e95fd1495c81717559d3fc5384dcc19f2182d3a348e4dcf2ea4d248e702e SHA512 6f647154c02825982d150588332801ad4c10c75cc5997b7825c0dd0381f48f6a3d09bf88346bc3e075891e77ca43a0a4c9f9c65962fd791085385c4229a1eb45
diff --git a/dev-ros/test_rosservice/test_rosservice-1.15.4.ebuild b/dev-ros/test_rosservice/test_rosservice-1.15.4.ebuild
new file mode 100644
index 000000000000..507361ef503e
--- /dev/null
+++ b/dev-ros/test_rosservice/test_rosservice-1.15.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rospy"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ test? (
+ dev-ros/test_rosmaster[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"