summaryrefslogtreecommitdiff
path: root/dev-ros/test_rospy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-ros/test_rospy
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-ros/test_rospy')
-rw-r--r--dev-ros/test_rospy/Manifest2
-rw-r--r--dev-ros/test_rospy/test_rospy-1.15.4.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-ros/test_rospy/Manifest b/dev-ros/test_rospy/Manifest
index e2f5304a2be0..bef3d7bf4c91 100644
--- a/dev-ros/test_rospy/Manifest
+++ b/dev-ros/test_rospy/Manifest
@@ -1,6 +1,8 @@
AUX py3-2.patch 2077 BLAKE2B 76b3289eb5a54e085d8ed2b687b70f53c047625a9b4216f4972f62702604192996b89d0469a5d927515c510f00a032919b40b9cd76db8e9e011c61fc37c50e28 SHA512 8b554bbc2a38e3d64a88e05921a8e0ed8271126e86f85f04bf0903224304a25df07530614435247a861b193c0a02a2fd0280488696f9196e6f3bf88b8e89da9e
AUX py3.patch 1169 BLAKE2B e73fa2afdde33f8fc921118b4bc1189b5f976a2dcc56f498890e1925c698b975c38dec6c6be24f7269e0dce83d2630eaba89b9aa925c249037720d15928d7a9d SHA512 8b5475d81200b724701e3f7312646105295f99d084e324f8990cc494609166d77b834309e19f36452133379682f33174d923d8fbb05f95a75306147c3bac154d
DIST ros_comm-1.14.3.tar.gz 1045287 BLAKE2B c079983aa730e70028d1bf2c365d01d99ce09ced0c0f6443b18f9d0fb83715f6af4b313d6db4eb99dcc10052c81fa3e6560e7b3591b2fbe14b9ec20fac24babe SHA512 52df24f10f476697ee6fa340da354b45431f35018a25e2674dc9306f175929a4b0368753503ea143f87aeb4945a2e67c37f83d833f54b53f9a76a81022c280a3
+DIST ros_comm-1.15.4.tar.gz 1071246 BLAKE2B 57867c192bfd48f3a0534762808c668031081a6155510879e68f9618226b9c5eff0d5fc9ec0e7ec8d0cc1f0d74794a4e55151036275ae6fc5bb613cc42137ddc SHA512 f92233cbf5ee97832023545730d3e756dfa08507072c074ac3e0763db1c2c2ab9fcbb0c90995a0c5d43f0ddc2ee528c185173a664b19abe4f8159aa3f3cb20dc
EBUILD test_rospy-1.14.3-r1.ebuild 902 BLAKE2B cc2d72203d6026d6c2fc9694bbbfe92f8af379ec3e0284b67684d30e432757834869710db15e0f546a8c817ccdd6f1cf6e145e68a4a2700ad694c6ca2a6d53bd SHA512 38ecb314607a3db7c111a889f885238a383208f89a8ee952356f44ece4669540f353e81be2d3c45fb3e5aef0c5b3a20c62f9c2db4316e91352caf601560998cb
+EBUILD test_rospy-1.15.4.ebuild 840 BLAKE2B a2b7bd4ee2342d2c780d470d94291bd7557e5ed974d869cffd65c0b06c3bf8be0dbf0621c5866972893c987acaf8e57da71ec05c7a5cc51e8cec9267a82626f6 SHA512 807a14b5886ae3b3e1e1bb230e47db02f9023ccb4c0f47cc4685a39d8e21576dbc1870fa441a33fbf5f84b82aaa4b77833f3eb1c6f488061dad8915d68b6b36c
EBUILD test_rospy-9999.ebuild 843 BLAKE2B 95bee07029a08cc289842cab2529c1854f1af6ea706853c51725ae88e6e50cad233090f48dfb4c203747a3e4d1fb7849caaf7daa3865730bc6bcb02e295cb77f SHA512 0351a18324e0c5c13cb36af850383a9c904ac8d5bd8f005dfafa6fa1e84a7a9377aaa8fd760036cc7057ee2d4f210f924fed6e65147da9a6c7676f31c75d54a0
MISC metadata.xml 326 BLAKE2B c8975866f4616482c71ac67084df89cea2643cc8233957c86450f7dba2ce320448e4e95fd1495c81717559d3fc5384dcc19f2182d3a348e4dcf2ea4d248e702e SHA512 6f647154c02825982d150588332801ad4c10c75cc5997b7825c0dd0381f48f6a3d09bf88346bc3e075891e77ca43a0a4c9f9c65962fd791085385c4229a1eb45
diff --git a/dev-ros/test_rospy/test_rospy-1.15.4.ebuild b/dev-ros/test_rospy/test_rospy-1.15.4.ebuild
new file mode 100644
index 000000000000..a60ab86abc52
--- /dev/null
+++ b/dev-ros/test_rospy/test_rospy-1.15.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/test_rosmaster"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rospy"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/std_msgs[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/test_rosmaster[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosunit[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-ros/rosbuild
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"