summaryrefslogtreecommitdiff
path: root/dev-ros/test_roscpp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-ros/test_roscpp
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-ros/test_roscpp')
-rw-r--r--dev-ros/test_roscpp/Manifest2
-rw-r--r--dev-ros/test_roscpp/test_roscpp-1.15.4.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-ros/test_roscpp/Manifest b/dev-ros/test_roscpp/Manifest
index 4ed5d0988cd2..8610b8f14a07 100644
--- a/dev-ros/test_roscpp/Manifest
+++ b/dev-ros/test_roscpp/Manifest
@@ -1,5 +1,7 @@
AUX boost.patch 1046 BLAKE2B f74c7018f277fa2cb525f68602599127eba9fa43cd29b706960de70c3757f9e4e22a3491f3f2d549a0c20abcdf70051449765bc0bad24bfb018a96b5f30022be SHA512 9391547e16815bd065bb467f13468c020006aaac0e49b6b86505ea3aefc110a2a342b47cf3c235fd5522d9881a8c9c85e142c15f00e4b1a627c6be9516738d37
DIST ros_comm-1.14.3.tar.gz 1045287 BLAKE2B c079983aa730e70028d1bf2c365d01d99ce09ced0c0f6443b18f9d0fb83715f6af4b313d6db4eb99dcc10052c81fa3e6560e7b3591b2fbe14b9ec20fac24babe SHA512 52df24f10f476697ee6fa340da354b45431f35018a25e2674dc9306f175929a4b0368753503ea143f87aeb4945a2e67c37f83d833f54b53f9a76a81022c280a3
+DIST ros_comm-1.15.4.tar.gz 1071246 BLAKE2B 57867c192bfd48f3a0534762808c668031081a6155510879e68f9618226b9c5eff0d5fc9ec0e7ec8d0cc1f0d74794a4e55151036275ae6fc5bb613cc42137ddc SHA512 f92233cbf5ee97832023545730d3e756dfa08507072c074ac3e0763db1c2c2ab9fcbb0c90995a0c5d43f0ddc2ee528c185173a664b19abe4f8159aa3f3cb20dc
EBUILD test_roscpp-1.14.3-r1.ebuild 721 BLAKE2B 2cfdd691aedc99cda218504cacc6eeffcc96c75eed937fca3d5c2c04235363cc7a876ac87f6af5f1c318616aecb6c4838ea9d970bb2ce5991eb488175cd334bc SHA512 cf2c48391e89b87a39e3d368907a711a7ed7b470ce6ddcb676bd83dfe21df9c66d060c238307b333a38f3221ddc1a1e0d0cbb3614f7609120a60b4b0e8706622
+EBUILD test_roscpp-1.15.4.ebuild 683 BLAKE2B 1b890234f56dcc228bb2d1846de3c9a52bd4083634fafbf433daabcef6a388c5a6f59df7a9c820b4edf8d79f900b3f51b06514315cb9e62c0e271cf68e66a32b SHA512 c0dd1645817bfadae0ba1865cc219802378fbaaf0782d03784f3d14857ebade42c2380578bba87814e31b38ea0c10706e35d7712b399c2b0515eb5a150328b5b
EBUILD test_roscpp-9999.ebuild 686 BLAKE2B 913ebd162894a4839ac240006a07f9007384d8066f71fcbef889b020b1283e5d528edc297e9f81497a984e152b6d0f1d91149bbaf0cdb437b2a6074ea51b9326 SHA512 88523b4bd636f6c066a7132bb0509c92cdfbfdbf24db72adef2c4461358c31c40f5c4f7db655aecbc41766429b50f73f1c7e247b7a956fefe2184e9079cd8df8
MISC metadata.xml 326 BLAKE2B c8975866f4616482c71ac67084df89cea2643cc8233957c86450f7dba2ce320448e4e95fd1495c81717559d3fc5384dcc19f2182d3a348e4dcf2ea4d248e702e SHA512 6f647154c02825982d150588332801ad4c10c75cc5997b7825c0dd0381f48f6a3d09bf88346bc3e075891e77ca43a0a4c9f9c65962fd791085385c4229a1eb45
diff --git a/dev-ros/test_roscpp/test_roscpp-1.15.4.ebuild b/dev-ros/test_roscpp/test_roscpp-1.15.4.ebuild
new file mode 100644
index 000000000000..e1720ee72889
--- /dev/null
+++ b/dev-ros/test_roscpp/test_roscpp-1.15.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/rosgraph_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for roscpp"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/roscpp
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/rosunit[${PYTHON_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-libs/boost:=[threads]
+ test? (
+ dev-cpp/gtest
+ )
+"
+REQUIRED_USE="test? ( ros_messages_cxx )"