summaryrefslogtreecommitdiff
path: root/dev-ros/smach_ros
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/smach_ros
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/smach_ros')
-rw-r--r--dev-ros/smach_ros/Manifest6
-rw-r--r--dev-ros/smach_ros/metadata.xml11
-rw-r--r--dev-ros/smach_ros/smach_ros-2.0.0.ebuild29
-rw-r--r--dev-ros/smach_ros/smach_ros-2.0.1.ebuild29
-rw-r--r--dev-ros/smach_ros/smach_ros-9999.ebuild29
5 files changed, 104 insertions, 0 deletions
diff --git a/dev-ros/smach_ros/Manifest b/dev-ros/smach_ros/Manifest
new file mode 100644
index 000000000000..b41260e775cc
--- /dev/null
+++ b/dev-ros/smach_ros/Manifest
@@ -0,0 +1,6 @@
+DIST executive_smach-2.0.0.tar.gz 39920 BLAKE2B 556e142927c5bdae710d575b03dbcd6f17151446264d8ff8e8978fd1d45222b1e5e8d9d8967cda8848101b8371b1738cffab638beb4d295437d314c2f399207c SHA512 e1970128f2a49e92e99821922351cb62c64d4367781397f6f6b3c20691c2712824edabe4e4a67264fe48555f3b0c8d1f1fd7bc8820fb6f5937f7c6a22815c601
+DIST executive_smach-2.0.1.tar.gz 42032 BLAKE2B 9271515a67436cd4873d4df5d1abae586af9ae856f9c90904732382e4824bd0bb23c820cd761017532604cde4c7c07ed4a98465b3267319dbc00b61b2d028dea SHA512 88be9ad6a0ec1e82e1592d26621fbbfe24e45640266f369cd03f192649bfd865e5a4ea576cf665161c0f89805e67b38b8b64b62a054ca1e217b99d8284f3b32a
+EBUILD smach_ros-2.0.0.ebuild 793 BLAKE2B 11603e66dd2d6601c7ab1ec5cf665667bef12fc5a8bd0fda067188b4e6c20a363de8cff8b936d4a85aa798a20c2ec91eb2b00e8bb2673f65b0759aceadd8c20d SHA512 e7051f2a5d375aa56c570cac30f8d0a1b9e6dfb33cd7732b484a8c4dcdd5513261143c579ec06f44ac21a8752a3ad05ea21caeac697aa601ae3f698b0daf3f99
+EBUILD smach_ros-2.0.1.ebuild 793 BLAKE2B 3bac339e753c23a87c590587e297597eed0828718b761ccabe308e88fa0188f941a84ec031278c2d5d0e739bd62e4cccb4b6f963501ab78acb3847bde4c0a34f SHA512 214de774ce0996f2544b54aa5c11c5924fe91622ff36d624ff8b795c23559d56fea814996cf42deaeb1206102f1904d76fbbd7330fc388dc9b71f9abf28729ad
+EBUILD smach_ros-9999.ebuild 793 BLAKE2B 11603e66dd2d6601c7ab1ec5cf665667bef12fc5a8bd0fda067188b4e6c20a363de8cff8b936d4a85aa798a20c2ec91eb2b00e8bb2673f65b0759aceadd8c20d SHA512 e7051f2a5d375aa56c570cac30f8d0a1b9e6dfb33cd7732b484a8c4dcdd5513261143c579ec06f44ac21a8752a3ad05ea21caeac697aa601ae3f698b0daf3f99
+MISC metadata.xml 333 BLAKE2B 9464368a741c4058fe2563c0a8a575e29bf8a74c43430a6c6f7be286419f675a560290c95d2afdf6e942843e233680e86886237a43ebe8d36136ebd36b4feb04 SHA512 c5e649958133658717bd4d1723953187a4c9626c7a1143fa784bc10ef533165bcb386248a42e20e9c1f7de4147e34c5a09f1009c5c65a78e2ed8fa0ccfc56165
diff --git a/dev-ros/smach_ros/metadata.xml b/dev-ros/smach_ros/metadata.xml
new file mode 100644
index 000000000000..d2fce8b37504
--- /dev/null
+++ b/dev-ros/smach_ros/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros/executive_smach</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/smach_ros/smach_ros-2.0.0.ebuild b/dev-ros/smach_ros/smach_ros-2.0.0.ebuild
new file mode 100644
index 000000000000..e2c6774ebe00
--- /dev/null
+++ b/dev-ros/smach_ros/smach_ros-2.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/executive_smach"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Extensions for the SMACH library to integrate it tightly with ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ dev-ros/actionlib[${PYTHON_USEDEP}]
+ dev-ros/smach[${PYTHON_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/actionlib_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/smach_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/smach_ros/smach_ros-2.0.1.ebuild b/dev-ros/smach_ros/smach_ros-2.0.1.ebuild
new file mode 100644
index 000000000000..d3df8eeab34e
--- /dev/null
+++ b/dev-ros/smach_ros/smach_ros-2.0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/executive_smach"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Extensions for the SMACH library to integrate it tightly with ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ dev-ros/actionlib[${PYTHON_USEDEP}]
+ dev-ros/smach[${PYTHON_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/actionlib_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/smach_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/smach_ros/smach_ros-9999.ebuild b/dev-ros/smach_ros/smach_ros-9999.ebuild
new file mode 100644
index 000000000000..e2c6774ebe00
--- /dev/null
+++ b/dev-ros/smach_ros/smach_ros-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/executive_smach"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Extensions for the SMACH library to integrate it tightly with ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ dev-ros/actionlib[${PYTHON_USEDEP}]
+ dev-ros/smach[${PYTHON_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/actionlib_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/smach_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"