summaryrefslogtreecommitdiff
path: root/dev-ros/shape_msgs/shape_msgs-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/shape_msgs/shape_msgs-9999.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/shape_msgs/shape_msgs-9999.ebuild')
-rw-r--r--dev-ros/shape_msgs/shape_msgs-9999.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-ros/shape_msgs/shape_msgs-9999.ebuild b/dev-ros/shape_msgs/shape_msgs-9999.ebuild
new file mode 100644
index 000000000000..90c7c9f3c861
--- /dev/null
+++ b/dev-ros/shape_msgs/shape_msgs-9999.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/common_msgs"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Messages for defining shapes, such as simple solid object primitives, planes, and meshes"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"