summaryrefslogtreecommitdiff
path: root/dev-ros/shape_msgs/shape_msgs-1.12.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-13 16:38:56 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-13 16:38:56 +0100
commitea31ad0ed5501d0bf92267c35beaf06ac016bad2 (patch)
tree2fdc433d571e3ead010876d43ce2646b7d783680 /dev-ros/shape_msgs/shape_msgs-1.12.6.ebuild
parent88ebe56470c37b02a044e1091cad6b2df0f3be8f (diff)
gentoo resync : 13.05.2018
Diffstat (limited to 'dev-ros/shape_msgs/shape_msgs-1.12.6.ebuild')
-rw-r--r--dev-ros/shape_msgs/shape_msgs-1.12.6.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-ros/shape_msgs/shape_msgs-1.12.6.ebuild b/dev-ros/shape_msgs/shape_msgs-1.12.6.ebuild
new file mode 100644
index 000000000000..b3071a70b84d
--- /dev/null
+++ b/dev-ros/shape_msgs/shape_msgs-1.12.6.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/common_msgs"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Messages for defining shapes, such as simple solid object primitives, planes, and meshes"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"