summaryrefslogtreecommitdiff
path: root/dev-ros/settlerlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/settlerlib
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/settlerlib')
-rw-r--r--dev-ros/settlerlib/Manifest5
-rw-r--r--dev-ros/settlerlib/files/gcc6.patch13
-rw-r--r--dev-ros/settlerlib/metadata.xml11
-rw-r--r--dev-ros/settlerlib/settlerlib-0.10.14.ebuild24
-rw-r--r--dev-ros/settlerlib/settlerlib-9999.ebuild23
5 files changed, 76 insertions, 0 deletions
diff --git a/dev-ros/settlerlib/Manifest b/dev-ros/settlerlib/Manifest
new file mode 100644
index 000000000000..e4370b07541e
--- /dev/null
+++ b/dev-ros/settlerlib/Manifest
@@ -0,0 +1,5 @@
+AUX gcc6.patch 537 BLAKE2B 21a31c5a9131e68c7b5acd22fac5d942daf7421416ea59b53d416041ef2300c1b0ce1d0d89a5268139cb83d98080db58544ad2679403f65fcc9a06cf97c61ba4 SHA512 d2de51575d8b6a16de4c72be2c1ac20a9a7383071036312954f375db22b403c8095113550d1a2de9dcff8dcac5ecb86c6f78e6a711ed9a2547a7870c82571d0b
+DIST calibration-0.10.14.tar.gz 112475 BLAKE2B a43bf316b3eea30f5f3e273e0dd2754fe819a1aa246237cb1ecc4bc49463abbd3eb71f77579fc0655c483ad9ac259bb027ac014fc5ec368a73bada61dedf6712 SHA512 5ef17cd21e04c134717859ecb12c4e7fc0086b044cf7d35d40bd43439a0f24e8ad41fe7b5fa37dcc8ec5e4abb2be8f64d86510706a3d97510cf1b92c2196ad40
+EBUILD settlerlib-0.10.14.ebuild 576 BLAKE2B c8d0e867a13328a1ab7043546839287e23128270d3e80e80d44fbc1c2148976e314eb1cf95cf1d100076fe30df2bce8e3b04dcdd5d8f69024d72f8bda13d5c27 SHA512 2d1e2618c5c4482f1800f45b58cea22be26655620204d78c440ed394279e106ffa5a6676b534e4e31114ee7d886d6574d310c92073c931385ef6f992b88ae13c
+EBUILD settlerlib-9999.ebuild 539 BLAKE2B a9e6046c7f43fdd917d6835514c654a792a3cef1a778dee410a55881cbdab5934ca00bd2c65520cf6071f1a7ca88c4658178143343e31f60b508905a93896115 SHA512 a156bb532ad1a8856b1889c68136190c8596868b65bdc767c265f418b027fae52787a87f923b9ead5204d1bd02e6157eaff784f601a2e5826aa3a58f65dc04a9
+MISC metadata.xml 340 BLAKE2B 52b47839e0051b2f1813313ae3989819be9668c093763a9c9518302d5b5832142fd02e6c7427493411d2b3ad3143d41180aa1c0f890362b43258109fc5b858b3 SHA512 de7b08cf3292d6c46f7a6e954ece0a32c8e2f4d67bc5212ce755662b8abf50425d54c00e0601ba943a4a9835f32c3df63ef87d5655788510ed86f05dd485a963
diff --git a/dev-ros/settlerlib/files/gcc6.patch b/dev-ros/settlerlib/files/gcc6.patch
new file mode 100644
index 000000000000..4fe3a03fbe5e
--- /dev/null
+++ b/dev-ros/settlerlib/files/gcc6.patch
@@ -0,0 +1,13 @@
+Index: settlerlib/CMakeLists.txt
+===================================================================
+--- settlerlib.orig/CMakeLists.txt
++++ settlerlib/CMakeLists.txt
+@@ -9,7 +9,7 @@ catkin_package(DEPENDS Boost calibration
+ )
+
+ # common commands for building c++ executables and libraries
+-include_directories(SYSTEM ${catkin_INCLUDE_DIRS})
++include_directories(${catkin_INCLUDE_DIRS})
+ include_directories(include)
+ install(DIRECTORY ${PROJECT_SOURCE_DIR}/include/settlerlib/
+ DESTINATION ${CATKIN_PACKAGE_INCLUDE_DESTINATION}
diff --git a/dev-ros/settlerlib/metadata.xml b/dev-ros/settlerlib/metadata.xml
new file mode 100644
index 000000000000..660014a7883d
--- /dev/null
+++ b/dev-ros/settlerlib/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros-perception/calibration</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/settlerlib/settlerlib-0.10.14.ebuild b/dev-ros/settlerlib/settlerlib-0.10.14.ebuild
new file mode 100644
index 000000000000..b012573d0e1c
--- /dev/null
+++ b/dev-ros/settlerlib/settlerlib-0.10.14.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/calibration"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Helper functions and routines to help creating a settler for a specific sensor channel"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-ros/calibration_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/rosconsole
+ dev-ros/rostime
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"
+PATCHES=( "${FILESDIR}/gcc6.patch" )
diff --git a/dev-ros/settlerlib/settlerlib-9999.ebuild b/dev-ros/settlerlib/settlerlib-9999.ebuild
new file mode 100644
index 000000000000..d55b85a8406d
--- /dev/null
+++ b/dev-ros/settlerlib/settlerlib-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/calibration"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Helper functions and routines to help creating a settler for a specific sensor channel"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-ros/calibration_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/rosconsole
+ dev-ros/rostime
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"