summaryrefslogtreecommitdiff
path: root/dev-ros/rqt_web/rqt_web-0.4.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-ros/rqt_web/rqt_web-0.4.9.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-ros/rqt_web/rqt_web-0.4.9.ebuild')
-rw-r--r--dev-ros/rqt_web/rqt_web-0.4.9.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/rqt_web/rqt_web-0.4.9.ebuild b/dev-ros/rqt_web/rqt_web-0.4.9.ebuild
new file mode 100644
index 000000000000..60b0b9016d48
--- /dev/null
+++ b/dev-ros/rqt_web/rqt_web-0.4.9.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_web"
+
+inherit ros-catkin
+
+DESCRIPTION="Simple web content viewer for rqt"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ $(python_gen_cond_dep "dev-python/rospkg[\${PYTHON_USEDEP}]")
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/qt_gui[${PYTHON_SINGLE_USEDEP}]
+"
+DEPEND="${RDEPEND}"