summaryrefslogtreecommitdiff
path: root/dev-ros/rqt_web/rqt_web-0.4.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ros/rqt_web/rqt_web-0.4.7.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ros/rqt_web/rqt_web-0.4.7.ebuild')
-rw-r--r--dev-ros/rqt_web/rqt_web-0.4.7.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/rqt_web/rqt_web-0.4.7.ebuild b/dev-ros/rqt_web/rqt_web-0.4.7.ebuild
new file mode 100644
index 000000000000..57716793e6bf
--- /dev/null
+++ b/dev-ros/rqt_web/rqt_web-0.4.7.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Simple web content viewer for rqt"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/qt_gui[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"