summaryrefslogtreecommitdiff
path: root/dev-ros/rqt_pose_view
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/rqt_pose_view
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/rqt_pose_view')
-rw-r--r--dev-ros/rqt_pose_view/Manifest4
-rw-r--r--dev-ros/rqt_pose_view/metadata.xml11
-rw-r--r--dev-ros/rqt_pose_view/rqt_pose_view-0.5.8.ebuild29
-rw-r--r--dev-ros/rqt_pose_view/rqt_pose_view-9999.ebuild29
4 files changed, 73 insertions, 0 deletions
diff --git a/dev-ros/rqt_pose_view/Manifest b/dev-ros/rqt_pose_view/Manifest
new file mode 100644
index 000000000000..b444ba8662c1
--- /dev/null
+++ b/dev-ros/rqt_pose_view/Manifest
@@ -0,0 +1,4 @@
+DIST rqt_pose_view-0.5.8.tar.gz 8299 BLAKE2B 6e8207b9d424c86871c274844251bafbfbb09789ce074cdd1d0e9b2c40361c473fdc2c3536b064eb06d6445f4eecba3aa1f380fe7f358a2eb68a1c2f7d385f70 SHA512 a3a53989c4fe73e6dfebea7e2f01fcd807faa0f011f452208ddb3df1be84939e7b1e26430a098f8b3a6554b781c9b0bf962ed0d115932dae5bc144225926f50b
+EBUILD rqt_pose_view-0.5.8.ebuild 754 BLAKE2B 758cc1afac80721aa8c3695c850ab4484403c1b53a0879a5ac57faf26fd9cf516758a26ad8567770eba4e2b3f80da44fb4ce7a8cc5c1e216677c004c0a60733f SHA512 f3729c92e30107e8574e10b6c02720221b2f30646bf1ef367b8a480320df849cb17bf3f72052ebe0719167eb5d17e5a38cea5d3ffb9eaf3c351e3a9d4290759b
+EBUILD rqt_pose_view-9999.ebuild 754 BLAKE2B 758cc1afac80721aa8c3695c850ab4484403c1b53a0879a5ac57faf26fd9cf516758a26ad8567770eba4e2b3f80da44fb4ce7a8cc5c1e216677c004c0a60733f SHA512 f3729c92e30107e8574e10b6c02720221b2f30646bf1ef367b8a480320df849cb17bf3f72052ebe0719167eb5d17e5a38cea5d3ffb9eaf3c351e3a9d4290759b
+MISC metadata.xml 345 BLAKE2B 0e6b4a4d3b8d1ff17491fe1cd16adb738771381f2e6d1279f68cc826f0931575864a63e6d2fa36af6a3897016125bce96df83ed43f5ef11df47cb955c0667ba0 SHA512 774daed773f2070d016eb616daa80e65f300c69ab1d436edf5aab5cc256f7e2ebdadf66a3c0fc5571ddb3dc496fd7353eed9dbf85cae48ae4f468dd4be95f22d
diff --git a/dev-ros/rqt_pose_view/metadata.xml b/dev-ros/rqt_pose_view/metadata.xml
new file mode 100644
index 000000000000..02b6f18344ab
--- /dev/null
+++ b/dev-ros/rqt_pose_view/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros-visualization/rqt_pose_view</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/rqt_pose_view/rqt_pose_view-0.5.8.ebuild b/dev-ros/rqt_pose_view/rqt_pose_view-0.5.8.ebuild
new file mode 100644
index 000000000000..f4b93343f49c
--- /dev/null
+++ b/dev-ros/rqt_pose_view/rqt_pose_view-0.5.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_pose_view"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for visualizing 3D poses"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-python/pyopengl[${PYTHON_USEDEP}]
+ dev-ros/python_qt_binding[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/tf[${PYTHON_USEDEP}]
+ dev-ros/rqt_py_common[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rqt_pose_view/rqt_pose_view-9999.ebuild b/dev-ros/rqt_pose_view/rqt_pose_view-9999.ebuild
new file mode 100644
index 000000000000..f4b93343f49c
--- /dev/null
+++ b/dev-ros/rqt_pose_view/rqt_pose_view-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_pose_view"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for visualizing 3D poses"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-python/pyopengl[${PYTHON_USEDEP}]
+ dev-ros/python_qt_binding[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/tf[${PYTHON_USEDEP}]
+ dev-ros/rqt_py_common[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"