summaryrefslogtreecommitdiff
path: root/dev-ros/rqt_pose_view/rqt_pose_view-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-ros/rqt_pose_view/rqt_pose_view-9999.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-ros/rqt_pose_view/rqt_pose_view-9999.ebuild')
-rw-r--r--dev-ros/rqt_pose_view/rqt_pose_view-9999.ebuild23
1 files changed, 11 insertions, 12 deletions
diff --git a/dev-ros/rqt_pose_view/rqt_pose_view-9999.ebuild b/dev-ros/rqt_pose_view/rqt_pose_view-9999.ebuild
index f4b93343f49c..903a748d5bfa 100644
--- a/dev-ros/rqt_pose_view/rqt_pose_view-9999.ebuild
+++ b/dev-ros/rqt_pose_view/rqt_pose_view-9999.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
KEYWORDS="~amd64"
ROS_REPO_URI="https://github.com/ros-visualization/rqt_pose_view"
-PYTHON_COMPAT=( python2_7 )
inherit ros-catkin
@@ -16,14 +15,14 @@ IUSE=""
RDEPEND="
dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-python/pyopengl[${PYTHON_USEDEP}]
- dev-ros/python_qt_binding[${PYTHON_USEDEP}]
- dev-python/rospkg[${PYTHON_USEDEP}]
- dev-ros/rospy[${PYTHON_USEDEP}]
- dev-ros/rostopic[${PYTHON_USEDEP}]
- dev-ros/rqt_gui[${PYTHON_USEDEP}]
- dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
- dev-ros/tf[${PYTHON_USEDEP}]
- dev-ros/rqt_py_common[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep "dev-python/pyopengl[\${PYTHON_USEDEP}]")
+ dev-ros/python_qt_binding[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/rospkg[\${PYTHON_USEDEP}]")
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rostopic[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/tf[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_py_common[${PYTHON_SINGLE_USEDEP}]
"
DEPEND="${RDEPEND}"