summaryrefslogtreecommitdiff
path: root/dev-ros/rqt_gui_py
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/rqt_gui_py
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/rqt_gui_py')
-rw-r--r--dev-ros/rqt_gui_py/Manifest6
-rw-r--r--dev-ros/rqt_gui_py/metadata.xml11
-rw-r--r--dev-ros/rqt_gui_py/rqt_gui_py-0.3.2.ebuild23
-rw-r--r--dev-ros/rqt_gui_py/rqt_gui_py-0.5.0.ebuild23
-rw-r--r--dev-ros/rqt_gui_py/rqt_gui_py-9999.ebuild23
5 files changed, 86 insertions, 0 deletions
diff --git a/dev-ros/rqt_gui_py/Manifest b/dev-ros/rqt_gui_py/Manifest
new file mode 100644
index 000000000000..d83d53a4859b
--- /dev/null
+++ b/dev-ros/rqt_gui_py/Manifest
@@ -0,0 +1,6 @@
+DIST rqt-0.3.2.tar.gz 96823 BLAKE2B 65d63ba2adb7d62a2b11bda20a170b3b91c25afea8b13ea658b879d134db391408bd559102a3dae3f9d8469f8c8fddbae13998b39fb58d58cd865b4817afc3c4 SHA512 0a1400b1b18e0e6374fd61801378df83d022687a90b3e0067ec70c490018ed9429b9fd5345caa7bc6236dedec099198457507988aa594d876cc6991a03b33916
+DIST rqt-0.5.0.tar.gz 120992 BLAKE2B 645d53ec7070fc5a40760bedc556328e26a16dea7b2990ad0512bc372cb346d545dbea42689b4c39039f17abc4920d5059e5b9a25ac7b77f8b5e5cc02100c5ac SHA512 5c91fe9bce5a7cb0cdc54b42667488d30c33bd57afd30cc8f2047b91b7aa7b8afd936090bfc76be5dbc8c6497623c1be4340e061503f5a65bc94faaad810597e
+EBUILD rqt_gui_py-0.3.2.ebuild 523 BLAKE2B 8cca293fb71e1e591b8611b09e0e348fb1bb3c7e8a6b0cb0d38849c54182f12cee7be0a8d25fab952c89fdaa5ad9fc4c4625dea0826f758af0371b048a60004f SHA512 34a74bc1b55c75fdf7723552f6e96319c2b78f75e31d00d7429411aee71621d03d2f3559c6f6abe3c40178457dd9fefde1ab57f0406a37da020c3e61931fb988
+EBUILD rqt_gui_py-0.5.0.ebuild 523 BLAKE2B 8cca293fb71e1e591b8611b09e0e348fb1bb3c7e8a6b0cb0d38849c54182f12cee7be0a8d25fab952c89fdaa5ad9fc4c4625dea0826f758af0371b048a60004f SHA512 34a74bc1b55c75fdf7723552f6e96319c2b78f75e31d00d7429411aee71621d03d2f3559c6f6abe3c40178457dd9fefde1ab57f0406a37da020c3e61931fb988
+EBUILD rqt_gui_py-9999.ebuild 523 BLAKE2B 8cca293fb71e1e591b8611b09e0e348fb1bb3c7e8a6b0cb0d38849c54182f12cee7be0a8d25fab952c89fdaa5ad9fc4c4625dea0826f758af0371b048a60004f SHA512 34a74bc1b55c75fdf7723552f6e96319c2b78f75e31d00d7429411aee71621d03d2f3559c6f6abe3c40178457dd9fefde1ab57f0406a37da020c3e61931fb988
+MISC metadata.xml 335 BLAKE2B 132c01d79a583ad6be876acab7644c890ccd31d44ee3ec46644eb005b56042ba1e687239dead37b4e592536493e82a74bfd22a99661a3945dfdf79448e9ca450 SHA512 d861666a6188e5bce041f76eedc1c3c18c8f1a185b5481e16f57481d7836f4fd71e9fb04b6f0c58c0cf4f5f77595e7675e2761699efdb2f697ec76cd6d0941f4
diff --git a/dev-ros/rqt_gui_py/metadata.xml b/dev-ros/rqt_gui_py/metadata.xml
new file mode 100644
index 000000000000..a016c2096bc5
--- /dev/null
+++ b/dev-ros/rqt_gui_py/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros-visualization/rqt</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/rqt_gui_py/rqt_gui_py-0.3.2.ebuild b/dev-ros/rqt_gui_py/rqt_gui_py-0.3.2.ebuild
new file mode 100644
index 000000000000..146f59212afe
--- /dev/null
+++ b/dev-ros/rqt_gui_py/rqt_gui_py-0.3.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/rqt"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Enables GUI plugins to use the Python client library for ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ >=dev-ros/qt_gui-0.3.0[${PYTHON_USEDEP}]
+ >=dev-ros/rqt_gui-0.3.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rqt_gui_py/rqt_gui_py-0.5.0.ebuild b/dev-ros/rqt_gui_py/rqt_gui_py-0.5.0.ebuild
new file mode 100644
index 000000000000..146f59212afe
--- /dev/null
+++ b/dev-ros/rqt_gui_py/rqt_gui_py-0.5.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/rqt"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Enables GUI plugins to use the Python client library for ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ >=dev-ros/qt_gui-0.3.0[${PYTHON_USEDEP}]
+ >=dev-ros/rqt_gui-0.3.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rqt_gui_py/rqt_gui_py-9999.ebuild b/dev-ros/rqt_gui_py/rqt_gui_py-9999.ebuild
new file mode 100644
index 000000000000..146f59212afe
--- /dev/null
+++ b/dev-ros/rqt_gui_py/rqt_gui_py-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/rqt"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Enables GUI plugins to use the Python client library for ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ >=dev-ros/qt_gui-0.3.0[${PYTHON_USEDEP}]
+ >=dev-ros/rqt_gui-0.3.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"