summaryrefslogtreecommitdiff
path: root/dev-ros/rqt_gui
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/rqt_gui
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/rqt_gui')
-rw-r--r--dev-ros/rqt_gui/Manifest5
-rw-r--r--dev-ros/rqt_gui/files/gentoo.patch15
-rw-r--r--dev-ros/rqt_gui/metadata.xml11
-rw-r--r--dev-ros/rqt_gui/rqt_gui-0.5.0.ebuild22
-rw-r--r--dev-ros/rqt_gui/rqt_gui-9999.ebuild22
5 files changed, 75 insertions, 0 deletions
diff --git a/dev-ros/rqt_gui/Manifest b/dev-ros/rqt_gui/Manifest
new file mode 100644
index 000000000000..5a16a965f79f
--- /dev/null
+++ b/dev-ros/rqt_gui/Manifest
@@ -0,0 +1,5 @@
+AUX gentoo.patch 765 BLAKE2B 0b0e46dae38aaf5f1bdce5e599b33cdbeff7ed8440f1537b31b559018a0a996cac7a66cdd1ae8935463b37b52a27e933669bd03a4f9617f0ba4de2665e223a4d SHA512 9d34f4e375c08c1b635359e1e9ec178577533e8f8aae99d0071c805a1765da11a4554a51d75ca524798a2d5ad121d4adb5392b9ad3a5f0704168b2bec2c7a38d
+DIST rqt-0.5.0.tar.gz 120992 BLAKE2B 645d53ec7070fc5a40760bedc556328e26a16dea7b2990ad0512bc372cb346d545dbea42689b4c39039f17abc4920d5059e5b9a25ac7b77f8b5e5cc02100c5ac SHA512 5c91fe9bce5a7cb0cdc54b42667488d30c33bd57afd30cc8f2047b91b7aa7b8afd936090bfc76be5dbc8c6497623c1be4340e061503f5a65bc94faaad810597e
+EBUILD rqt_gui-0.5.0.ebuild 534 BLAKE2B d3694ed4e3ad22fa0e48db8871f12568e0851e287d0421c85b23ebcb6c700b9f4f74264c844918c85e7806ba6de57c068d755ff58459d350f1e515dad6bc2287 SHA512 960002db838c3a37f05e445f9998232dce0db40cd53689f7c79d65d97d10bfd723fec9789d08c42747da228dbf6a2734bddf9d190645497fd4807758fed7a643
+EBUILD rqt_gui-9999.ebuild 534 BLAKE2B d3694ed4e3ad22fa0e48db8871f12568e0851e287d0421c85b23ebcb6c700b9f4f74264c844918c85e7806ba6de57c068d755ff58459d350f1e515dad6bc2287 SHA512 960002db838c3a37f05e445f9998232dce0db40cd53689f7c79d65d97d10bfd723fec9789d08c42747da228dbf6a2734bddf9d190645497fd4807758fed7a643
+MISC metadata.xml 335 BLAKE2B 132c01d79a583ad6be876acab7644c890ccd31d44ee3ec46644eb005b56042ba1e687239dead37b4e592536493e82a74bfd22a99661a3945dfdf79448e9ca450 SHA512 d861666a6188e5bce041f76eedc1c3c18c8f1a185b5481e16f57481d7836f4fd71e9fb04b6f0c58c0cf4f5f77595e7675e2761699efdb2f697ec76cd6d0941f4
diff --git a/dev-ros/rqt_gui/files/gentoo.patch b/dev-ros/rqt_gui/files/gentoo.patch
new file mode 100644
index 000000000000..abdc30a8ccbd
--- /dev/null
+++ b/dev-ros/rqt_gui/files/gentoo.patch
@@ -0,0 +1,15 @@
+Index: rqt_gui/src/rqt_gui/ros_plugin_provider.py
+===================================================================
+--- rqt_gui.orig/src/rqt_gui/ros_plugin_provider.py
++++ rqt_gui/src/rqt_gui/ros_plugin_provider.py
+@@ -109,6 +109,10 @@ class RosPluginProvider(PluginProvider):
+ def _parse_plugin_xml(self, package_name, plugin_xml):
+ plugin_descriptors = []
+
++ # Gentoo: strip ros_packages to get the real path.
++ if not os.path.isfile(plugin_xml):
++ plugin_xml = plugin_xml.replace('ros_packages/', '')
++
+ if not os.path.isfile(plugin_xml):
+ qCritical('RosPluginProvider._parse_plugin_xml() plugin file "%s" in package "%s" not found' % (plugin_xml, package_name))
+ return plugin_descriptors
diff --git a/dev-ros/rqt_gui/metadata.xml b/dev-ros/rqt_gui/metadata.xml
new file mode 100644
index 000000000000..a016c2096bc5
--- /dev/null
+++ b/dev-ros/rqt_gui/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros-visualization/rqt</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/rqt_gui/rqt_gui-0.5.0.ebuild b/dev-ros/rqt_gui/rqt_gui-0.5.0.ebuild
new file mode 100644
index 000000000000..2f20b99ad0df
--- /dev/null
+++ b/dev-ros/rqt_gui/rqt_gui-0.5.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/rqt"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Main to start an instance of the ROS integrated graphical user interface provided by qt_gui"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-ros/qt_gui-0.3.0[${PYTHON_USEDEP}]
+ dev-libs/boost:="
+DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/gentoo.patch" )
diff --git a/dev-ros/rqt_gui/rqt_gui-9999.ebuild b/dev-ros/rqt_gui/rqt_gui-9999.ebuild
new file mode 100644
index 000000000000..2f20b99ad0df
--- /dev/null
+++ b/dev-ros/rqt_gui/rqt_gui-9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/rqt"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Main to start an instance of the ROS integrated graphical user interface provided by qt_gui"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-ros/qt_gui-0.3.0[${PYTHON_USEDEP}]
+ dev-libs/boost:="
+DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/gentoo.patch" )