summaryrefslogtreecommitdiff
path: root/dev-ros/rqt_graph/rqt_graph-0.4.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ros/rqt_graph/rqt_graph-0.4.9.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ros/rqt_graph/rqt_graph-0.4.9.ebuild')
-rw-r--r--dev-ros/rqt_graph/rqt_graph-0.4.9.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/rqt_graph/rqt_graph-0.4.9.ebuild b/dev-ros/rqt_graph/rqt_graph-0.4.9.ebuild
new file mode 100644
index 000000000000..1f2bff4c39fc
--- /dev/null
+++ b/dev-ros/rqt_graph/rqt_graph-0.4.9.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_graph"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for visualizing the ROS computation graph"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_dotgraph[${PYTHON_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rosnode[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rosservice[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"