summaryrefslogtreecommitdiff
path: root/dev-ros/rqt_action
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ros/rqt_action
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ros/rqt_action')
-rw-r--r--dev-ros/rqt_action/Manifest5
-rw-r--r--dev-ros/rqt_action/metadata.xml11
-rw-r--r--dev-ros/rqt_action/rqt_action-0.4.9.ebuild22
-rw-r--r--dev-ros/rqt_action/rqt_action-9999.ebuild22
4 files changed, 60 insertions, 0 deletions
diff --git a/dev-ros/rqt_action/Manifest b/dev-ros/rqt_action/Manifest
new file mode 100644
index 000000000000..7f92cdd3ca46
--- /dev/null
+++ b/dev-ros/rqt_action/Manifest
@@ -0,0 +1,5 @@
+DIST rqt_action-0.4.9.tar.gz 3288 SHA256 6f69d38f7770efd6da560c5c95438fbbed25fd2bea06e34421ed6aae2655a46c SHA512 e412fe23bca87f2fc55a858ddc153ecfd6fcf7bdc60334d09285e3d44ab6d2cc52680f29d3bfd4fe9ad5bc334c595b311fcea5e835223dd61c19fd0de0489afc WHIRLPOOL 788bba2cdbb7f76f12b7c71afebc0cee0d52cd06fbd1669ad89eb7efec87df125002f49b4ab7648334b2f8c9c877199e38e6d28595c0e9950eadcf86b4d85215
+EBUILD rqt_action-0.4.9.ebuild 492 SHA256 f7610ad9e340f8ac917bbf1ab019678fe160b2c8887b5293c093174a7ec007f2 SHA512 89cda35a955c3fef8184abe5a9e57d187c531d385ee538812e6bf165d174dc95406bef6a6fc75c12f3fc6c6528544c35aa4f37e9681f11a6e74be8b4d073bab3 WHIRLPOOL 40fb1e5e31fbf59dcbf9be128e23cd7fb72b49a93b84b03e0a53e4c424ca40f7de28cacdbda4049bf001654a793bb47901fab29cf311205cccb1a6aeb0f96509
+EBUILD rqt_action-9999.ebuild 492 SHA256 f7610ad9e340f8ac917bbf1ab019678fe160b2c8887b5293c093174a7ec007f2 SHA512 89cda35a955c3fef8184abe5a9e57d187c531d385ee538812e6bf165d174dc95406bef6a6fc75c12f3fc6c6528544c35aa4f37e9681f11a6e74be8b4d073bab3 WHIRLPOOL 40fb1e5e31fbf59dcbf9be128e23cd7fb72b49a93b84b03e0a53e4c424ca40f7de28cacdbda4049bf001654a793bb47901fab29cf311205cccb1a6aeb0f96509
+MISC ChangeLog 2172 SHA256 6bb789458deab7db4ab50da66bc6d5197f7470484f352eca7ba45125335959b3 SHA512 5819a71eaf3376180a206ce3dc070af909ff1a80cfaf9de8fd0ed5d6b836fbc480bc8c2d5bf0df6c4ade06391242c1c69a6f0b85d89326801b57074fe60217bf WHIRLPOOL 9672dca0014040b5f7700891f89bd9193d62a82b1dcfa44a91116ea22fdd26ad7c9ca270f119e41d566e4b94a93c4d606c7b66b53aebe201d27ec8a93f88d819
+MISC metadata.xml 342 SHA256 9c3eb24ba585d8a32c8557f8113e78d918d983fd5ef0d2eb5fde709cf82971b6 SHA512 d68ea776973eee1600ca75e3cec47e4db57d8f14f0b2ac796276d48763f71c513ac1deebfbe6e76261fd5af8f394981c05dd9dcf3b47c7b0029a46443cf10d1c WHIRLPOOL 97f31903f382005ebe3b45dfc8033515cffe1b82c43a42b2da57a278d9743402a0731efa0073e59aaff185a385dda4f296fee8b42f9c54ece1d1330d99892779
diff --git a/dev-ros/rqt_action/metadata.xml b/dev-ros/rqt_action/metadata.xml
new file mode 100644
index 000000000000..e5c138054234
--- /dev/null
+++ b/dev-ros/rqt_action/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros-visualization/rqt_action</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/rqt_action/rqt_action-0.4.9.ebuild b/dev-ros/rqt_action/rqt_action-0.4.9.ebuild
new file mode 100644
index 000000000000..d368b9658f68
--- /dev/null
+++ b/dev-ros/rqt_action/rqt_action-0.4.9.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_action"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Introspect all available ROS action (from actionlib) types"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_msg[${PYTHON_USEDEP}]
+ dev-ros/rqt_py_common[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rqt_action/rqt_action-9999.ebuild b/dev-ros/rqt_action/rqt_action-9999.ebuild
new file mode 100644
index 000000000000..d368b9658f68
--- /dev/null
+++ b/dev-ros/rqt_action/rqt_action-9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_action"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Introspect all available ROS action (from actionlib) types"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_msg[${PYTHON_USEDEP}]
+ dev-ros/rqt_py_common[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"