summaryrefslogtreecommitdiff
path: root/dev-ros/rotate_recovery
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/rotate_recovery
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/rotate_recovery')
-rw-r--r--dev-ros/rotate_recovery/Manifest6
-rw-r--r--dev-ros/rotate_recovery/metadata.xml11
-rw-r--r--dev-ros/rotate_recovery/rotate_recovery-1.15.1-r1.ebuild28
-rw-r--r--dev-ros/rotate_recovery/rotate_recovery-1.15.2.ebuild28
-rw-r--r--dev-ros/rotate_recovery/rotate_recovery-9999.ebuild28
5 files changed, 101 insertions, 0 deletions
diff --git a/dev-ros/rotate_recovery/Manifest b/dev-ros/rotate_recovery/Manifest
new file mode 100644
index 000000000000..b02b0d13b384
--- /dev/null
+++ b/dev-ros/rotate_recovery/Manifest
@@ -0,0 +1,6 @@
+DIST navigation-1.15.1.tar.gz 346480 BLAKE2B 29f9a0b6f2c62bd21a7cb87a64b490c845bb7db4af338fd094744abb22402df7eedc8c164b64f93f2d67dabaff99ca3b946b45e93173bed74834d9e3668726ad SHA512 25c5093bf7acca9d15d46bb2d0ae7e4ce0fa45f18b32d1626668dcbd33732317e8535b978e7225d86391472c517f05acb7736f31a7c511c8736ab8a22c7af4b0
+DIST navigation-1.15.2.tar.gz 348985 BLAKE2B 866779425828b1e4c3a044654ae41f33643646ca70cf6841f23bce265add2c420bf0934a41a6b29fa65fc421228a31dc15e9fb0f6cc4295ce12adbbb627b43d4 SHA512 582422756b31b4d83e929e3c723e7205e772b9775fcf618c9bd5d3c54af1f20e9bc8a0143626750c0c3cffeb0cbea8f8706b7e66f62dc037cfe12b05f23ee142
+EBUILD rotate_recovery-1.15.1-r1.ebuild 606 BLAKE2B 73f5ab04b5649cb806a00032935bda90516a782879bd554194a066bb9b97328affb91340b355528ac6c876688b90e14019b8618bfe70e5bb126abf777ba37644 SHA512 bb82c834a6b960be12782707a845485e18e56c29a92f68425e6b40d3d7d4ce212f4b5fadb70abe69aa4f36cfc19c5df651b7f89db3948219a2cf1d185ad42167
+EBUILD rotate_recovery-1.15.2.ebuild 606 BLAKE2B 2070356def81d0003474a0405ffd5466922e6aa5421af7b5d65ef451bf955e025f54cca1d8e1a10b18cc8c4bfc35d070a11172049fcfc211b3bb8be8148d165a SHA512 959150d508d21f213ac70df41e12ad9e1cf4a0e8f147610d12feeeee7b211405eaf17ed58afe932e8506fc271d53aebb83aa7c79a87b5db5f04fcad2e7fc8a5d
+EBUILD rotate_recovery-9999.ebuild 606 BLAKE2B 73f5ab04b5649cb806a00032935bda90516a782879bd554194a066bb9b97328affb91340b355528ac6c876688b90e14019b8618bfe70e5bb126abf777ba37644 SHA512 bb82c834a6b960be12782707a845485e18e56c29a92f68425e6b40d3d7d4ce212f4b5fadb70abe69aa4f36cfc19c5df651b7f89db3948219a2cf1d185ad42167
+MISC metadata.xml 337 BLAKE2B ecfbf3d0b63a1b876065d04b3d52daa0442e3bcaf060836731012a1e698b3aea06ff292d892035feb2fb0fc257d6d8462d013ccc67f2650177c9cdba4d051d44 SHA512 f5df7464100fa15a3d2ad11cc620007500a5cb5ea7be67ac45819a541dd4ae53ce476231d475acf4dfe7e7bf0c31281325dc4e003867d1cc01a29353bb5ea09e
diff --git a/dev-ros/rotate_recovery/metadata.xml b/dev-ros/rotate_recovery/metadata.xml
new file mode 100644
index 000000000000..7408fdf7047f
--- /dev/null
+++ b/dev-ros/rotate_recovery/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros-planning/navigation</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/rotate_recovery/rotate_recovery-1.15.1-r1.ebuild b/dev-ros/rotate_recovery/rotate_recovery-1.15.1-r1.ebuild
new file mode 100644
index 000000000000..a31e4f6d10c8
--- /dev/null
+++ b/dev-ros/rotate_recovery/rotate_recovery-1.15.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Recovery behavior that attempts to clear space by performing a 360 degree rotation of the robot"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/costmap_2d
+ dev-ros/nav_core
+ dev-ros/pluginlib
+ dev-ros/base_local_planner
+ dev-cpp/eigen:3
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules"
diff --git a/dev-ros/rotate_recovery/rotate_recovery-1.15.2.ebuild b/dev-ros/rotate_recovery/rotate_recovery-1.15.2.ebuild
new file mode 100644
index 000000000000..f66e208f7dfe
--- /dev/null
+++ b/dev-ros/rotate_recovery/rotate_recovery-1.15.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Recovery behavior that attempts to clear space by performing a 360 degree rotation of the robot"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/costmap_2d
+ dev-ros/nav_core
+ dev-ros/pluginlib
+ dev-ros/base_local_planner
+ dev-cpp/eigen:3
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules"
diff --git a/dev-ros/rotate_recovery/rotate_recovery-9999.ebuild b/dev-ros/rotate_recovery/rotate_recovery-9999.ebuild
new file mode 100644
index 000000000000..a31e4f6d10c8
--- /dev/null
+++ b/dev-ros/rotate_recovery/rotate_recovery-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Recovery behavior that attempts to clear space by performing a 360 degree rotation of the robot"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/costmap_2d
+ dev-ros/nav_core
+ dev-ros/pluginlib
+ dev-ros/base_local_planner
+ dev-cpp/eigen:3
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules"