summaryrefslogtreecommitdiff
path: root/dev-ros/rotate_recovery/rotate_recovery-1.16.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /dev-ros/rotate_recovery/rotate_recovery-1.16.1.ebuild
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'dev-ros/rotate_recovery/rotate_recovery-1.16.1.ebuild')
-rw-r--r--dev-ros/rotate_recovery/rotate_recovery-1.16.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/rotate_recovery/rotate_recovery-1.16.1.ebuild b/dev-ros/rotate_recovery/rotate_recovery-1.16.1.ebuild
new file mode 100644
index 000000000000..149998080211
--- /dev/null
+++ b/dev-ros/rotate_recovery/rotate_recovery-1.16.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Recovery behavior that attempts to clear space by performing a 360 degree rotation of the robot"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/costmap_2d
+ dev-cpp/eigen:3
+ >=dev-ros/nav_core-1.16
+ dev-ros/pluginlib
+ dev-ros/roscpp
+ dev-ros/tf2_ros
+
+ dev-ros/base_local_planner
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules"