summaryrefslogtreecommitdiff
path: root/dev-ros/roswtf/roswtf-1.13.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ros/roswtf/roswtf-1.13.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ros/roswtf/roswtf-1.13.1.ebuild')
-rw-r--r--dev-ros/roswtf/roswtf-1.13.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/roswtf/roswtf-1.13.1.ebuild b/dev-ros/roswtf/roswtf-1.13.1.ebuild
new file mode 100644
index 000000000000..beab39855484
--- /dev/null
+++ b/dev-ros/roswtf/roswtf-1.13.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=utilities/${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Tool for diagnosing issues with a running ROS system"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-util/rosdep[${PYTHON_USEDEP}]
+ dev-util/rosinstall[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"