summaryrefslogtreecommitdiff
path: root/dev-ros/rosunit/rosunit-1.14.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-ros/rosunit/rosunit-1.14.7.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-ros/rosunit/rosunit-1.14.7.ebuild')
-rw-r--r--dev-ros/rosunit/rosunit-1.14.7.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/rosunit/rosunit-1.14.7.ebuild b/dev-ros/rosunit/rosunit-1.14.7.ebuild
new file mode 100644
index 000000000000..af7d4b220e08
--- /dev/null
+++ b/dev-ros/rosunit/rosunit-1.14.7.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_5,3_6} pypy{,3} )
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Unit-testing package for ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"