summaryrefslogtreecommitdiff
path: root/dev-ros/rosunit/rosunit-1.14.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
commitf78108598211053d41752a83e0345441bb9014ae (patch)
treedd2fc7ae0a1aea7bda4942ab0c453d1e55284b37 /dev-ros/rosunit/rosunit-1.14.3.ebuild
parentdc45b83b28fb83e9659492066e347b8dc60bc9e3 (diff)
gentoo resync : 11.02.2018
Diffstat (limited to 'dev-ros/rosunit/rosunit-1.14.3.ebuild')
-rw-r--r--dev-ros/rosunit/rosunit-1.14.3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/rosunit/rosunit-1.14.3.ebuild b/dev-ros/rosunit/rosunit-1.14.3.ebuild
new file mode 100644
index 000000000000..eb257dfeac25
--- /dev/null
+++ b/dev-ros/rosunit/rosunit-1.14.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Unit-testing package for ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"