summaryrefslogtreecommitdiff
path: root/dev-ros/rostopic/rostopic-1.13.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ros/rostopic/rostopic-1.13.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ros/rostopic/rostopic-1.13.1.ebuild')
-rw-r--r--dev-ros/rostopic/rostopic-1.13.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/rostopic/rostopic-1.13.1.ebuild b/dev-ros/rostopic/rostopic-1.13.1.ebuild
new file mode 100644
index 000000000000..32a1e1924956
--- /dev/null
+++ b/dev-ros/rostopic/rostopic-1.13.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit ros-catkin
+
+DESCRIPTION="Command-line tool for displaying debug information about ROS Topics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosbag[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"