summaryrefslogtreecommitdiff
path: root/dev-ros/rostime/rostime-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ros/rostime/rostime-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ros/rostime/rostime-9999.ebuild')
-rw-r--r--dev-ros/rostime/rostime-9999.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/rostime/rostime-9999.ebuild b/dev-ros/rostime/rostime-9999.ebuild
new file mode 100644
index 000000000000..d6af114604b5
--- /dev/null
+++ b/dev-ros/rostime/rostime-9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/roscpp_core"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Time and Duration implementations for C++ libraries"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-ros/cpp_common
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )
+"