summaryrefslogtreecommitdiff
path: root/dev-ros/rosserial_xbee/rosserial_xbee-0.7.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-06 18:23:20 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-06 18:23:20 +0000
commitd37b97a25b8b10f748eead6574b01f893f140b01 (patch)
tree13e2a142a31cd193a39c63042a64cab29a1f7ae9 /dev-ros/rosserial_xbee/rosserial_xbee-0.7.7.ebuild
parenta833e3f4a431b8eea751b7420e127787f9c92117 (diff)
gentoo resync : 06.12.2017
Diffstat (limited to 'dev-ros/rosserial_xbee/rosserial_xbee-0.7.7.ebuild')
-rw-r--r--dev-ros/rosserial_xbee/rosserial_xbee-0.7.7.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/rosserial_xbee/rosserial_xbee-0.7.7.ebuild b/dev-ros/rosserial_xbee/rosserial_xbee-0.7.7.ebuild
new file mode 100644
index 000000000000..4e936b3e9784
--- /dev/null
+++ b/dev-ros/rosserial_xbee/rosserial_xbee-0.7.7.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-drivers/rosserial"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Tools to do point to multipoint communication between rosserial nodes connected to an xbee"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-python/pyserial[${PYTHON_USEDEP}]
+ dev-ros/rosserial_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosserial_python[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"