summaryrefslogtreecommitdiff
path: root/dev-ros/rospack
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/rospack
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/rospack')
-rw-r--r--dev-ros/rospack/Manifest7
-rw-r--r--dev-ros/rospack/files/gentoo.patch18
-rw-r--r--dev-ros/rospack/metadata.xml11
-rw-r--r--dev-ros/rospack/rospack-2.4.3.ebuild31
-rw-r--r--dev-ros/rospack/rospack-2.5.0.ebuild31
-rw-r--r--dev-ros/rospack/rospack-9999.ebuild31
6 files changed, 129 insertions, 0 deletions
diff --git a/dev-ros/rospack/Manifest b/dev-ros/rospack/Manifest
new file mode 100644
index 000000000000..2a846367cc63
--- /dev/null
+++ b/dev-ros/rospack/Manifest
@@ -0,0 +1,7 @@
+AUX gentoo.patch 576 BLAKE2B e53b90591c46bc876d0cebdbeb660257c8a5ff3fe7aebc3d895a04011f1bb0fb004fecb375157f3d70811203445db11f2b6bd51e6994ecca71ce9cc132ee33b7 SHA512 85bc49da821ff4a31d6cff838f2ff006625f0f5041c2bfa8f742c92173c48fc6d2a4601e370058478afe66e1b0aa5e237964b950554c40710f9f411e1e04bbad
+DIST rospack-2.4.3.tar.gz 72327 BLAKE2B b154ce307ed95403382030c0fe14bd6296174289333fea83356a4f77add0fe2a1e48c8e2b6ee037def2e823f61a7b6df4ea62fd9a6f84433f12247003823f86f SHA512 4396ef24d0bd826235d7ac0da8a0b502557ecc0086eadcda96d44779ed5d8134e9a53cd861ee135a4b1da53074bdcf906dc4cb6ea0c36798326c17788ee1e2be
+DIST rospack-2.5.0.tar.gz 72447 BLAKE2B 820e893544b38464bfc63b516697fac9e5875bfffb0922aa0da4b572af5e47a0f4a63134786131fd0ae97751916748b0a1e6af6ca29897ef72759b601bffb551 SHA512 8c9ed4566aa1456b2dd3c4249f7023121d21ee99427d0ef78a7237fbe418f333859091b66870572d5a80995ebda9d5208643ae92213827af40c63b49be4a2560
+EBUILD rospack-2.4.3.ebuild 564 BLAKE2B b20791ff8bab8e5d800a0de2ddcbcb94900ac52797dafa4e3c3a8ec4e93389015f1424e4f44f92b79193872c80a1569b3abb15e877150629365a4184427eedfc SHA512 9814190d49aa220554bf3a440e781642eeefbb5f1b5126c1b74e0fbe98ddd946327f38973fe7215b27b0de6d5a799af221940659c51294fd28906423e3be19be
+EBUILD rospack-2.5.0.ebuild 568 BLAKE2B a840a0e1f4ef10e1366d6b8c71df812f92930604464da318aa7593c4e00b1fe9f7b83c603086f9cb4c7977f917c2501b1796e4602cceab55dde64637f64eda8d SHA512 ab3a5283d2a7c6e55ae7e9f526338296baea9aa151b22facb07c0ca604348b7c520527e4586ccda1078005ede35be56bbd1321f98552a5b354132a4a8dd8bb04
+EBUILD rospack-9999.ebuild 568 BLAKE2B a840a0e1f4ef10e1366d6b8c71df812f92930604464da318aa7593c4e00b1fe9f7b83c603086f9cb4c7977f917c2501b1796e4602cceab55dde64637f64eda8d SHA512 ab3a5283d2a7c6e55ae7e9f526338296baea9aa151b22facb07c0ca604348b7c520527e4586ccda1078005ede35be56bbd1321f98552a5b354132a4a8dd8bb04
+MISC metadata.xml 325 BLAKE2B 5a5a1c31afa5d12425b09321ce006e4e921cf4bb4b90748045afd58cedbb4e67534dc16c27d338ed759586efb03ddda6ce053cf744025fe7e489320d9b271ca4 SHA512 2718fee8c06627957b95d0e99b517d2dcb2428279925a22e6cbbab1e56ea6d25da57c7143d316e7406419b7d2ff75187950957a705348adfb4008413923dda5c
diff --git a/dev-ros/rospack/files/gentoo.patch b/dev-ros/rospack/files/gentoo.patch
new file mode 100644
index 000000000000..7090d7b02dd7
--- /dev/null
+++ b/dev-ros/rospack/files/gentoo.patch
@@ -0,0 +1,18 @@
+Index: rospack-2.3.1/src/rospack.cpp
+===================================================================
+--- rospack-2.3.1.orig/src/rospack.cpp
++++ rospack-2.3.1/src/rospack.cpp
+@@ -191,6 +191,13 @@ class Stackage
+ break;
+ }
+ }
++
++ // On Gentoo we move package.xml to /usr/share/ros_packages/... but need to keep standard stuff in /usr/share, so correct this here.
++ try {
++ fs::path p = fs::canonical("../../" + name_, path_);
++ path_ = p.string();
++ }
++ catch(fs::filesystem_error& e) {};
+ }
+
+ bool isStack() const
diff --git a/dev-ros/rospack/metadata.xml b/dev-ros/rospack/metadata.xml
new file mode 100644
index 000000000000..38f7385bd7d2
--- /dev/null
+++ b/dev-ros/rospack/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros/rospack</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/rospack/rospack-2.4.3.ebuild b/dev-ros/rospack/rospack-2.4.3.ebuild
new file mode 100644
index 000000000000..18b9f633ad3f
--- /dev/null
+++ b/dev-ros/rospack/rospack-2.4.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/rospack"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Retrieves information about ROS packages available on the filesystem"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-libs/tinyxml2:=
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ >=dev-ros/cmake_modules-0.4.1
+ test? (
+ dev-cpp/gtest
+ dev-python/nose
+ )"
+
+PATCHES=(
+ "${FILESDIR}/gentoo.patch"
+)
diff --git a/dev-ros/rospack/rospack-2.5.0.ebuild b/dev-ros/rospack/rospack-2.5.0.ebuild
new file mode 100644
index 000000000000..cf86c350e8c7
--- /dev/null
+++ b/dev-ros/rospack/rospack-2.5.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/rospack"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Retrieves information about ROS packages available on the filesystem"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ dev-libs/boost:=
+ >=dev-libs/tinyxml2-5:=
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ >=dev-ros/cmake_modules-0.4.1
+ test? (
+ dev-cpp/gtest
+ dev-python/nose
+ )"
+
+PATCHES=(
+ "${FILESDIR}/gentoo.patch"
+)
diff --git a/dev-ros/rospack/rospack-9999.ebuild b/dev-ros/rospack/rospack-9999.ebuild
new file mode 100644
index 000000000000..cf86c350e8c7
--- /dev/null
+++ b/dev-ros/rospack/rospack-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/rospack"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Retrieves information about ROS packages available on the filesystem"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ dev-libs/boost:=
+ >=dev-libs/tinyxml2-5:=
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ >=dev-ros/cmake_modules-0.4.1
+ test? (
+ dev-cpp/gtest
+ dev-python/nose
+ )"
+
+PATCHES=(
+ "${FILESDIR}/gentoo.patch"
+)