summaryrefslogtreecommitdiff
path: root/dev-ros/roslz4/roslz4-1.15.14.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-ros/roslz4/roslz4-1.15.14.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-ros/roslz4/roslz4-1.15.14.ebuild')
-rw-r--r--dev-ros/roslz4/roslz4-1.15.14.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-ros/roslz4/roslz4-1.15.14.ebuild b/dev-ros/roslz4/roslz4-1.15.14.ebuild
new file mode 100644
index 000000000000..38046fb7703f
--- /dev/null
+++ b/dev-ros/roslz4/roslz4-1.15.14.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=utilities/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Python and C++ implementation of the LZ4 streaming format"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="app-arch/lz4
+ dev-ros/cpp_common"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"