summaryrefslogtreecommitdiff
path: root/dev-ros/roslz4/roslz4-1.15.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
commitd162ba1860a88062f4cd61f8b52fc303ba0b2991 (patch)
tree24cd2cf57f3932a24b96e4a0f6666489447e43ba /dev-ros/roslz4/roslz4-1.15.11.ebuild
parent590b9b7b03bf4651e099949e318755af7cfa81b8 (diff)
gentoo resync : 07.08.2021
Diffstat (limited to 'dev-ros/roslz4/roslz4-1.15.11.ebuild')
-rw-r--r--dev-ros/roslz4/roslz4-1.15.11.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-ros/roslz4/roslz4-1.15.11.ebuild b/dev-ros/roslz4/roslz4-1.15.11.ebuild
new file mode 100644
index 000000000000..bcbd9d65b47d
--- /dev/null
+++ b/dev-ros/roslz4/roslz4-1.15.11.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=utilities/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Python and C++ implementation of the LZ4 streaming format"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="app-arch/lz4
+ dev-ros/cpp_common"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"