summaryrefslogtreecommitdiff
path: root/dev-ros/roslisp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/roslisp
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/roslisp')
-rw-r--r--dev-ros/roslisp/Manifest4
-rw-r--r--dev-ros/roslisp/metadata.xml11
-rw-r--r--dev-ros/roslisp/roslisp-1.9.21.ebuild23
-rw-r--r--dev-ros/roslisp/roslisp-9999.ebuild23
4 files changed, 61 insertions, 0 deletions
diff --git a/dev-ros/roslisp/Manifest b/dev-ros/roslisp/Manifest
new file mode 100644
index 000000000000..4f5705e4d30d
--- /dev/null
+++ b/dev-ros/roslisp/Manifest
@@ -0,0 +1,4 @@
+DIST roslisp-1.9.21.tar.gz 116725 BLAKE2B 9aac16c816b94c019da16e7379c84d06614f75665823d24806b432a94e05187b00791f16cf2d86f69f8bdb3d569ffcba8eacad24dc07ca90c2a720ec2aa40ccc SHA512 f9988d9da8c80b75e57f764082a372e260f0a6fd5837ef30855b78dc8cf22a1f6eefd08a70136d29602bd163793201f3e4d6204e5d433069c58b8d751dd458e1
+EBUILD roslisp-1.9.21.ebuild 397 BLAKE2B c9eb928c922b7c3b8f28ad7dd93266dc3a5e4a231268ff179f90643e688b03f0ef5b0af963b4876ff9fc8118c0dfa2db343b6705d5869119ee6c5ed685af41cf SHA512 bbee77877d83d647235e31bd692c90ca373e0b0af55d4c7ccbc48846451b18a7e1098081bdb3993b27aebfdedcbff5943fbaa016588f88c33198de42911bcb20
+EBUILD roslisp-9999.ebuild 397 BLAKE2B 7758ed4c583ee252596b9339b9ed750db0ad4a6919caa22f9de828c4dcffbbcf92c28a552d8b45d41d94bb506b14d10c36d1bd0df49ff9be2e099b9a96cbee59 SHA512 1a2b7b80e54b1e11f9ec7e8defb700b9b12a17c15081e6d95a3004b44a71b325f0983ffcd9b6113dc2d943de558bcf66095ecba9923f94f7d1ee90ce9ac4b2e0
+MISC metadata.xml 325 BLAKE2B c0fc43b32a0177d24f912ce281b2944049a23b10091e42b6554706b252ebc91acac09bd2b2a61fd06255c1adc949f7c9ed2fce19f5127db240e84d7f21af9318 SHA512 adaa5720c07e49aca1c5d959e88a0ff844c00529165adc0c1f1533197c9c55c5e7332beb1d3c2cdefab001eee6305004557e76bd4cd7e48c0a23274218b0bbfb
diff --git a/dev-ros/roslisp/metadata.xml b/dev-ros/roslisp/metadata.xml
new file mode 100644
index 000000000000..410201129ac7
--- /dev/null
+++ b/dev-ros/roslisp/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros/roslisp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/roslisp/roslisp-1.9.21.ebuild b/dev-ros/roslisp/roslisp-1.9.21.ebuild
new file mode 100644
index 000000000000..e7a4c6bb23c0
--- /dev/null
+++ b/dev-ros/roslisp/roslisp-1.9.21.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/roslisp"
+KEYWORDS="~amd64"
+
+inherit ros-catkin
+
+DESCRIPTION="Lisp client library for ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roslang
+ dev-lisp/sbcl
+ dev-ros/rospack
+ dev-ros/rosgraph_msgs
+ dev-ros/std_srvs
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/roslisp/roslisp-9999.ebuild b/dev-ros/roslisp/roslisp-9999.ebuild
new file mode 100644
index 000000000000..13e083962d01
--- /dev/null
+++ b/dev-ros/roslisp/roslisp-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/roslisp"
+KEYWORDS="~amd64"
+
+inherit ros-catkin
+
+DESCRIPTION="Lisp client library for ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roslang
+ dev-lisp/sbcl
+ dev-ros/rospack
+ dev-ros/rosgraph_msgs
+ dev-ros/std_srvs
+"
+DEPEND="${RDEPEND}"