summaryrefslogtreecommitdiff
path: root/dev-ros/roslib/roslib-1.14.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/roslib/roslib-1.14.1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/roslib/roslib-1.14.1.ebuild')
-rw-r--r--dev-ros/roslib/roslib-1.14.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/roslib/roslib-1.14.1.ebuild b/dev-ros/roslib/roslib-1.14.1.ebuild
new file mode 100644
index 000000000000..1866c312cfe9
--- /dev/null
+++ b/dev-ros/roslib/roslib-1.14.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+ROS_SUBDIR=core/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Base dependencies and support libraries for ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/rospkg-1.0.37[${PYTHON_USEDEP}]
+ dev-libs/boost:=[threads]
+ dev-ros/rospack
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-cpp/gtest
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+PATCHES=( "${FILESDIR}/envhook.patch" )