summaryrefslogtreecommitdiff
path: root/dev-ros/rosgraph_msgs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ros/rosgraph_msgs
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ros/rosgraph_msgs')
-rw-r--r--dev-ros/rosgraph_msgs/Manifest5
-rw-r--r--dev-ros/rosgraph_msgs/metadata.xml11
-rw-r--r--dev-ros/rosgraph_msgs/rosgraph_msgs-1.11.2.ebuild21
-rw-r--r--dev-ros/rosgraph_msgs/rosgraph_msgs-9999.ebuild21
4 files changed, 58 insertions, 0 deletions
diff --git a/dev-ros/rosgraph_msgs/Manifest b/dev-ros/rosgraph_msgs/Manifest
new file mode 100644
index 000000000000..19666561a20a
--- /dev/null
+++ b/dev-ros/rosgraph_msgs/Manifest
@@ -0,0 +1,5 @@
+DIST ros_comm_msgs-1.11.2.tar.gz 2482 SHA256 7bb9f57ea9e6c5fb0599b247736f4f3b7868d722344fb42bc3055b31626ea250 SHA512 4750e234725b3cad8e2deb681f827e2f979f50bdfc0fccf4100288d2f663a68561f363702340b4569572837462cf6578f51213362d18b9694f6952fdcede1e6e WHIRLPOOL b7e5f9995c839491026f96a20e859f434282e335efc76cfce4779958d31b9ea1402f37c543273aea0fe7b17cca5ac79730a884a2b2221979e31dddd1a202d725
+EBUILD rosgraph_msgs-1.11.2.ebuild 462 SHA256 fc3b1813e7ee234ab2c9800060a1fd88b1be513e3b9fab499c7601b8430d54ac SHA512 3e26a724e154053c170592d33931d0dc7e082ed6983a76823b5b5bd55f4e48d6815d452ec923fc9ffbfea046788b536ac3dbcedbdb75ce81a9a27c9870fb60aa WHIRLPOOL c901a5f15ec42d7bc4b51d00f6a535f0e66e6ee4b15fe6e71ae17a579ada918c6cf324fa0c41c14de021c4535eaf099c9d46f72493d6c4199644248e6d9206f0
+EBUILD rosgraph_msgs-9999.ebuild 462 SHA256 fc3b1813e7ee234ab2c9800060a1fd88b1be513e3b9fab499c7601b8430d54ac SHA512 3e26a724e154053c170592d33931d0dc7e082ed6983a76823b5b5bd55f4e48d6815d452ec923fc9ffbfea046788b536ac3dbcedbdb75ce81a9a27c9870fb60aa WHIRLPOOL c901a5f15ec42d7bc4b51d00f6a535f0e66e6ee4b15fe6e71ae17a579ada918c6cf324fa0c41c14de021c4535eaf099c9d46f72493d6c4199644248e6d9206f0
+MISC ChangeLog 1730 SHA256 6640752f2b79fd29fde481ce0fe62a96a82ff09ebf152105d8b643973577dbbc SHA512 642dd97e45620410ba3ae6c03c2f24a65daef9aa9db417abd43e7469813519dc41549dc528a16f8f8a9b89353e1f7d6d0b6a9cf54ed5f16a5a5863aee6af009e WHIRLPOOL 3f519ccb23b937efff220f704a63729fe9348047d116694300e2aa03b55b71cb44e25de294562f47cfd5e1a1bf3e4ee4a722510c1b39190d1414b0cca46cbc9e
+MISC metadata.xml 331 SHA256 46adb48408b3ab1dc609a725cb808378aa3dbddbe3620a947a7cbbec39dea0ee SHA512 365791913afec69e27e8c220acd643eb6ac8e13419a04d38a672a9ba50e696719563b246207abe70a1b945e42c1b61c3348f543f4d7a66b0b6cf62668769cf64 WHIRLPOOL 6c6ae8b6ebcdb97f2ac5200569d81d5291b28527108ba2f6fb91849251363e3b1e0e9b2af7b18573ee4e4064e972055ecc73904219b01a62ed614638f3977756
diff --git a/dev-ros/rosgraph_msgs/metadata.xml b/dev-ros/rosgraph_msgs/metadata.xml
new file mode 100644
index 000000000000..04e520df2773
--- /dev/null
+++ b/dev-ros/rosgraph_msgs/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros/ros_comm_msgs</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/rosgraph_msgs/rosgraph_msgs-1.11.2.ebuild b/dev-ros/rosgraph_msgs/rosgraph_msgs-1.11.2.ebuild
new file mode 100644
index 000000000000..85e36c5258ec
--- /dev/null
+++ b/dev-ros/rosgraph_msgs/rosgraph_msgs-1.11.2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/ros_comm_msgs"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Messages relating to ROS comm"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rosgraph_msgs/rosgraph_msgs-9999.ebuild b/dev-ros/rosgraph_msgs/rosgraph_msgs-9999.ebuild
new file mode 100644
index 000000000000..85e36c5258ec
--- /dev/null
+++ b/dev-ros/rosgraph_msgs/rosgraph_msgs-9999.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/ros_comm_msgs"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Messages relating to ROS comm"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"