summaryrefslogtreecommitdiff
path: root/dev-ros/rosgraph/rosgraph-1.14.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-ros/rosgraph/rosgraph-1.14.3-r1.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-ros/rosgraph/rosgraph-1.14.3-r1.ebuild')
-rw-r--r--dev-ros/rosgraph/rosgraph-1.14.3-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/rosgraph/rosgraph-1.14.3-r1.ebuild b/dev-ros/rosgraph/rosgraph-1.14.3-r1.ebuild
new file mode 100644
index 000000000000..4a463741c8fc
--- /dev/null
+++ b/dev-ros/rosgraph/rosgraph-1.14.3-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_5,3_6} pypy{,3} )
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Prints information about the ROS Computation Graph"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/netifaces[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )"
+PATCHES=( "${FILESDIR}/yaml.patch" "${FILESDIR}/py3.patch" "${FILESDIR}/py3-2.patch" )