summaryrefslogtreecommitdiff
path: root/dev-ros/rosdiagnostic/rosdiagnostic-1.9.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ros/rosdiagnostic/rosdiagnostic-1.9.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ros/rosdiagnostic/rosdiagnostic-1.9.2.ebuild')
-rw-r--r--dev-ros/rosdiagnostic/rosdiagnostic-1.9.2.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ros/rosdiagnostic/rosdiagnostic-1.9.2.ebuild b/dev-ros/rosdiagnostic/rosdiagnostic-1.9.2.ebuild
new file mode 100644
index 000000000000..e68fe9061c60
--- /dev/null
+++ b/dev-ros/rosdiagnostic/rosdiagnostic-1.9.2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/diagnostics"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+inherit ros-catkin
+
+DESCRIPTION="Command to print aggregated diagnostic contents to the command line"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"