summaryrefslogtreecommitdiff
path: root/dev-ros/rosdiagnostic/rosdiagnostic-1.10.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-ros/rosdiagnostic/rosdiagnostic-1.10.4.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-ros/rosdiagnostic/rosdiagnostic-1.10.4.ebuild')
-rw-r--r--dev-ros/rosdiagnostic/rosdiagnostic-1.10.4.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-ros/rosdiagnostic/rosdiagnostic-1.10.4.ebuild b/dev-ros/rosdiagnostic/rosdiagnostic-1.10.4.ebuild
new file mode 100644
index 000000000000..e28046b6462d
--- /dev/null
+++ b/dev-ros/rosdiagnostic/rosdiagnostic-1.10.4.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros/diagnostics"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Command to print aggregated diagnostic contents to the command line"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+"
+RDEPEND="${DEPEND}"