summaryrefslogtreecommitdiff
path: root/dev-ros/rosbridge_library/rosbridge_library-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-ros/rosbridge_library/rosbridge_library-9999.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-ros/rosbridge_library/rosbridge_library-9999.ebuild')
-rw-r--r--dev-ros/rosbridge_library/rosbridge_library-9999.ebuild24
1 files changed, 12 insertions, 12 deletions
diff --git a/dev-ros/rosbridge_library/rosbridge_library-9999.ebuild b/dev-ros/rosbridge_library/rosbridge_library-9999.ebuild
index 9ebd079262d5..0e9d84e423a4 100644
--- a/dev-ros/rosbridge_library/rosbridge_library-9999.ebuild
+++ b/dev-ros/rosbridge_library/rosbridge_library-9999.ebuild
@@ -1,34 +1,34 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
CATKIN_HAS_MESSAGES=yes
ROS_REPO_URI="https://github.com/RobotWebTools/rosbridge_suite"
KEYWORDS="~amd64"
-PYTHON_COMPAT=( python2_7 )
ROS_SUBDIR=${PN}
CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs"
inherit ros-catkin
-DESCRIPTION="Core rosbridge package responsible for interpreting JSON and performing the appropriate ROS action"
+DESCRIPTION="Core rosbridge package for parsing JSON and performing the appropriate action"
LICENSE="BSD"
SLOT="0"
IUSE=""
RDEPEND="
- dev-ros/rospy[${PYTHON_USEDEP}]
- dev-ros/rosservice[${PYTHON_USEDEP}]
- dev-ros/rostopic[${PYTHON_USEDEP}]
- dev-ros/rosgraph[${PYTHON_USEDEP}]
- dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/roscpp[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rosservice[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rostopic[${PYTHON_SINGLE_USEDEP}]
dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-python/pymongo[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/cbor[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep "dev-python/pillow[\${PYTHON_USEDEP}]")
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ $(python_gen_cond_dep "dev-python/pymongo[\${PYTHON_USEDEP}]")
"
DEPEND="${RDEPEND}
test? (
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
dev-ros/actionlib_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
dev-ros/nav_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]