summaryrefslogtreecommitdiff
path: root/dev-ros/rosauth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ros/rosauth
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ros/rosauth')
-rw-r--r--dev-ros/rosauth/Manifest5
-rw-r--r--dev-ros/rosauth/metadata.xml11
-rw-r--r--dev-ros/rosauth/rosauth-0.1.7.ebuild22
-rw-r--r--dev-ros/rosauth/rosauth-9999.ebuild22
4 files changed, 60 insertions, 0 deletions
diff --git a/dev-ros/rosauth/Manifest b/dev-ros/rosauth/Manifest
new file mode 100644
index 000000000000..49eea74e379d
--- /dev/null
+++ b/dev-ros/rosauth/Manifest
@@ -0,0 +1,5 @@
+DIST rosauth-0.1.7.tar.gz 6060 SHA256 c85c4163c94d20bce9864180785210bfe3dfd110114f18212bd711d1be87c48e SHA512 c52317cd173ec655b779f96ffe324cd136a54168484f26fff2a0d9fe2da6e25cc5109f1905d7528a9f6a433287873b63c53f96ec425ca6af740d4eea0b3250b5 WHIRLPOOL 9a21f936bea44735f3dbaf413cb9fbd93f7d673e186f99f7c7eff284d3187c44d096c1635a094cd35ce04a0909558ae174b16bb3a5d3ffe19022f655a8bc9238
+EBUILD rosauth-0.1.7.ebuild 521 SHA256 cdddcf3d2d119d2ad0b5a379b05981b90b69e657efc4022dc20fe6010768c62b SHA512 de1fdc087a008c79872a41081061c73d2f5168c8cb07c83874cd1c5d9ae2ad2adbea95daf34b6af611664c133b0d7fb8c733ab28b793a076f69352715c437b42 WHIRLPOOL 9e70c5f37548250d10a3dd5e1460127233a0d4c5206b1aaf9160e2338cb41a5a3f7a1bf76d34cafc79a077def0c8d263a494cef69237c6ec4970f0e5653e1e5c
+EBUILD rosauth-9999.ebuild 521 SHA256 cdddcf3d2d119d2ad0b5a379b05981b90b69e657efc4022dc20fe6010768c62b SHA512 de1fdc087a008c79872a41081061c73d2f5168c8cb07c83874cd1c5d9ae2ad2adbea95daf34b6af611664c133b0d7fb8c733ab28b793a076f69352715c437b42 WHIRLPOOL 9e70c5f37548250d10a3dd5e1460127233a0d4c5206b1aaf9160e2338cb41a5a3f7a1bf76d34cafc79a077def0c8d263a494cef69237c6ec4970f0e5653e1e5c
+MISC ChangeLog 1277 SHA256 7eb00962b9f758484079a8993ee8a0ddf7397e95da9308b7c91f3b620363c4a0 SHA512 2d530272c4e4a206a92935a03c1ee4aea1dc862701de30d4dbb2a06f2e9e352d7e507fa386d2c1eed677072c39385985eb56a673dd8ce10290ffaa0cb9c8e9e5 WHIRLPOOL 6563e995f86ca8322d449a71ebd7fd3ce9691704bd2f3ff59e623cbe18c69f5018310cd16418f1530837b9120270b7fb60ee1f2b8004cbcb9e7a9e1f2b8ed8af
+MISC metadata.xml 330 SHA256 ad0e1a74c6d0ee2d53ee09b9d7a3c8a7f3936238f7ee6da9fed57308b085ebde SHA512 de7596aebaeef7ac6d148cb8c88573f98c76b28fa6adbd322260ea28c96ed58315c7e855941f572bf3d10b5351acd545dfcfc92d02fdad5b34e7824e72e29070 WHIRLPOOL 5fdc43f084119fab859a94564bfd9890516df12e947395ccc394426e70bbbd338f301ec34fc544567ad5dd589f8a6db50cb6f91079389b1e12edce032daa6bfa
diff --git a/dev-ros/rosauth/metadata.xml b/dev-ros/rosauth/metadata.xml
new file mode 100644
index 000000000000..e8a311eb20f2
--- /dev/null
+++ b/dev-ros/rosauth/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">WPI-RAIL/rosauth</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/rosauth/rosauth-0.1.7.ebuild b/dev-ros/rosauth/rosauth-0.1.7.ebuild
new file mode 100644
index 000000000000..372b30e6a355
--- /dev/null
+++ b/dev-ros/rosauth/rosauth-0.1.7.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/WPI-RAIL/rosauth"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Server Side tools for Authorization and Authentication of ROS Clients"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-libs/openssl:0="
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"
diff --git a/dev-ros/rosauth/rosauth-9999.ebuild b/dev-ros/rosauth/rosauth-9999.ebuild
new file mode 100644
index 000000000000..372b30e6a355
--- /dev/null
+++ b/dev-ros/rosauth/rosauth-9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/WPI-RAIL/rosauth"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Server Side tools for Authorization and Authentication of ROS Clients"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-libs/openssl:0="
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"