summaryrefslogtreecommitdiff
path: root/dev-ros/rosauth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-ros/rosauth
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-ros/rosauth')
-rw-r--r--dev-ros/rosauth/Manifest6
-rw-r--r--dev-ros/rosauth/rosauth-1.0.1.ebuild (renamed from dev-ros/rosauth/rosauth-0.1.7.ebuild)19
-rw-r--r--dev-ros/rosauth/rosauth-9999.ebuild19
3 files changed, 29 insertions, 15 deletions
diff --git a/dev-ros/rosauth/Manifest b/dev-ros/rosauth/Manifest
index 2c52a08e8f7e..9630fb6b8375 100644
--- a/dev-ros/rosauth/Manifest
+++ b/dev-ros/rosauth/Manifest
@@ -1,4 +1,4 @@
-DIST rosauth-0.1.7.tar.gz 6060 BLAKE2B 5b53de7f61d66c68ec91e64668dd8009d4c6087795efae8d96540c6db4a34480f8a262fc75f0b3bfc52817650157c5df921f077ffba4c972dca9461aff0dea58 SHA512 c52317cd173ec655b779f96ffe324cd136a54168484f26fff2a0d9fe2da6e25cc5109f1905d7528a9f6a433287873b63c53f96ec425ca6af740d4eea0b3250b5
-EBUILD rosauth-0.1.7.ebuild 521 BLAKE2B e666ba089ef09cc85f3fceead99d2bf9c366b72daade82cb341a6a8056c1749e3139b830384b886fac31e118dbfd900d1e1d22cc57c64d541d3ba11b83cd1214 SHA512 de1fdc087a008c79872a41081061c73d2f5168c8cb07c83874cd1c5d9ae2ad2adbea95daf34b6af611664c133b0d7fb8c733ab28b793a076f69352715c437b42
-EBUILD rosauth-9999.ebuild 521 BLAKE2B e666ba089ef09cc85f3fceead99d2bf9c366b72daade82cb341a6a8056c1749e3139b830384b886fac31e118dbfd900d1e1d22cc57c64d541d3ba11b83cd1214 SHA512 de1fdc087a008c79872a41081061c73d2f5168c8cb07c83874cd1c5d9ae2ad2adbea95daf34b6af611664c133b0d7fb8c733ab28b793a076f69352715c437b42
+DIST rosauth-1.0.1.tar.gz 6209 BLAKE2B a87db7cd226919007c500465f84099500cdcdd32705603cbcd2b70bfa1d2ce0da4534b1cda1ae76f698cd2568fb6d4c4ec4dc836f43ecf67054ad2f8121daeba SHA512 5fb0b02bf6edc92c49a7572cb3ddd441094c0a6a9f1a69e7ab03097f859562426f39351da2d4e9e63de4a3558033d46a606f10117a63362b1e0a8e73cbbdda11
+EBUILD rosauth-1.0.1.ebuild 571 BLAKE2B 6bf7cc4f4b217c8835c8354c2c8f21fccf2f61e1c63f87c45cd05b28e4fc69435c64a4f8c44e7731fbb35db205a603983fbddbd92d84034d7d0e9f0258c63113 SHA512 f7736b54ea3015d4319477caba2285e705f08c8418156d3f475af5dfee4e5104ace8437d6c2e77d4c22f7793dee3b689e123338e0df3cac09155f4156f99917f
+EBUILD rosauth-9999.ebuild 571 BLAKE2B 6bf7cc4f4b217c8835c8354c2c8f21fccf2f61e1c63f87c45cd05b28e4fc69435c64a4f8c44e7731fbb35db205a603983fbddbd92d84034d7d0e9f0258c63113 SHA512 f7736b54ea3015d4319477caba2285e705f08c8418156d3f475af5dfee4e5104ace8437d6c2e77d4c22f7793dee3b689e123338e0df3cac09155f4156f99917f
MISC metadata.xml 330 BLAKE2B b7647904cd15b02dd3107c10d156d5dc9ff7dec2dd67014402afe7b2f99ecc127f07bf971ff40a86ae0f414f43750ffda75f1814802c689816da11ed1bd0f6f1 SHA512 de7596aebaeef7ac6d148cb8c88573f98c76b28fa6adbd322260ea28c96ed58315c7e855941f572bf3d10b5351acd545dfcfc92d02fdad5b34e7824e72e29070
diff --git a/dev-ros/rosauth/rosauth-0.1.7.ebuild b/dev-ros/rosauth/rosauth-1.0.1.ebuild
index 372b30e6a355..10f5ea08a15f 100644
--- a/dev-ros/rosauth/rosauth-0.1.7.ebuild
+++ b/dev-ros/rosauth/rosauth-1.0.1.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
CATKIN_HAS_MESSAGES=yes
ROS_REPO_URI="https://github.com/WPI-RAIL/rosauth"
KEYWORDS="~amd64"
-PYTHON_COMPAT=( python2_7 )
inherit ros-catkin
@@ -16,7 +15,15 @@ IUSE=""
RDEPEND="
dev-ros/roscpp
- dev-ros/rostest[${PYTHON_USEDEP}]
- dev-libs/openssl:0="
+ dev-libs/openssl:0=
+"
DEPEND="${RDEPEND}
- test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"
+ test? (
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ dev-cpp/gtest
+ )"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}
diff --git a/dev-ros/rosauth/rosauth-9999.ebuild b/dev-ros/rosauth/rosauth-9999.ebuild
index 372b30e6a355..10f5ea08a15f 100644
--- a/dev-ros/rosauth/rosauth-9999.ebuild
+++ b/dev-ros/rosauth/rosauth-9999.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
CATKIN_HAS_MESSAGES=yes
ROS_REPO_URI="https://github.com/WPI-RAIL/rosauth"
KEYWORDS="~amd64"
-PYTHON_COMPAT=( python2_7 )
inherit ros-catkin
@@ -16,7 +15,15 @@ IUSE=""
RDEPEND="
dev-ros/roscpp
- dev-ros/rostest[${PYTHON_USEDEP}]
- dev-libs/openssl:0="
+ dev-libs/openssl:0=
+"
DEPEND="${RDEPEND}
- test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"
+ test? (
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ dev-cpp/gtest
+ )"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}