summaryrefslogtreecommitdiff
path: root/dev-ros/rosapi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/rosapi
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/rosapi')
-rw-r--r--dev-ros/rosapi/Manifest6
-rw-r--r--dev-ros/rosapi/metadata.xml11
-rw-r--r--dev-ros/rosapi/rosapi-0.8.6.ebuild25
-rw-r--r--dev-ros/rosapi/rosapi-0.9.0.ebuild25
-rw-r--r--dev-ros/rosapi/rosapi-9999.ebuild25
5 files changed, 92 insertions, 0 deletions
diff --git a/dev-ros/rosapi/Manifest b/dev-ros/rosapi/Manifest
new file mode 100644
index 000000000000..677603d6dda1
--- /dev/null
+++ b/dev-ros/rosapi/Manifest
@@ -0,0 +1,6 @@
+DIST rosbridge_suite-0.8.6.tar.gz 378267 BLAKE2B b5e72b7897feef66aa05603bcff00ba213844f700f56be97a7110f33a77e3aa848ca0c583d5509ee205dc01bf001181b1887e20ee89d8348bc5eb43fd5a829b0 SHA512 e935c20466a13cbcf00051a4f32bc981806244aecf314e09e9e0ca9e0e873ab098b14b5ca5839bf14f2d3dfb823ecc62bb4e26027d4d0ff3f52bf0385011fbf3
+DIST rosbridge_suite-0.9.0.tar.gz 89409 BLAKE2B e48f36b71d8c5bcbd1ede0a87015b231d45194f3410b4cfcc38d39089477418b1f40afb28d8df7beba2e5e99b4aafde53bbc3f9bf371f0434099d7730c6393ee SHA512 4d7a6c0c33da9bf42ff24a0add81cad5fec707ef7149bf929bd2aac92ea2fe6f42da21bd5349dadee05cacb69d7efdb7adb0c01fc01c8251e0503cb488a73364
+EBUILD rosapi-0.8.6.ebuild 666 BLAKE2B 4a5f2c91cbbac4dfd373c467b4c8161c159a20666350d6c498d54fb1cee3b3c9f47ba535b9d9d9d342ffdf473c095c392a806b727da9f51e87a5590196889ddb SHA512 f9d3f52c6681107c6c51af0f18a09c849187d7ba29361fa56bec76792e6eecc1d5d9f5e900405c5dcc2947046bb7bf3c090a90883d9c346d7973a158d16dbbfa
+EBUILD rosapi-0.9.0.ebuild 666 BLAKE2B 510dbf0f6129e666050621d4430f1e7107e51553aed8f4e70f18b611957fbe4c0e0e9ac4ddf301ff160efce8ec2dfef2d9c29e91898eb0a4adc2a526234b2d91 SHA512 b85e31287a3d3a3ef628ec346d125beafcc30023c12127a16aed0192790bc71db425c709e1b6e91d24c50e5492a768b08f5519a7e92f866ba5d3c48ebc275819
+EBUILD rosapi-9999.ebuild 666 BLAKE2B b72ae518fb0e55ae5140173b5798d487958bec6d00c702fda74f9566528eb1cb6a90b280f8ad213020409f85a0d29adc7312edce80b478546774b56a17ede0bd SHA512 08c596717d0acdd3255ddf0908aea6bd3f9ac722a29345e52bc973b26c3c155b6e6118ab03dc6dd8ea55cab2caa13f40a7352da8377d196ffbada60987c015db
+MISC metadata.xml 343 BLAKE2B 54e565b139250d84a9adfb768099d530c91876a8d20dabdb1c5fdb61c7c4e799b3e4121ad704c09b8019693ccbf15be426100cdc8e9388f8ef68312d4ca75d31 SHA512 45889c0aa111bcf8050244d51f15ceef5501a722f3feac93c3795a4b9217a41098f44f6b06f906ff333e2c98d03b0f44e4a41d1acdc70942fa9c54b05dde1365
diff --git a/dev-ros/rosapi/metadata.xml b/dev-ros/rosapi/metadata.xml
new file mode 100644
index 000000000000..b99398ddaaba
--- /dev/null
+++ b/dev-ros/rosapi/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">RobotWebTools/rosbridge_suite</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/rosapi/rosapi-0.8.6.ebuild b/dev-ros/rosapi/rosapi-0.8.6.ebuild
new file mode 100644
index 000000000000..348d9a4fa5f0
--- /dev/null
+++ b/dev-ros/rosapi/rosapi-0.8.6.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/RobotWebTools/rosbridge_suite"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Provides service calls for getting ros meta-information, like list of topics, services, params, etc."
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rosnode[${PYTHON_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rosbridge_library[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rosapi/rosapi-0.9.0.ebuild b/dev-ros/rosapi/rosapi-0.9.0.ebuild
new file mode 100644
index 000000000000..b157089b594a
--- /dev/null
+++ b/dev-ros/rosapi/rosapi-0.9.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/RobotWebTools/rosbridge_suite"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Provides service calls for getting ros meta-information, like list of topics, services, params, etc."
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rosnode[${PYTHON_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rosbridge_library[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rosapi/rosapi-9999.ebuild b/dev-ros/rosapi/rosapi-9999.ebuild
new file mode 100644
index 000000000000..c22242d34dcc
--- /dev/null
+++ b/dev-ros/rosapi/rosapi-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/RobotWebTools/rosbridge_suite"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Provides service calls for getting ros meta-information, like list of topics, services, params, etc."
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rosnode[${PYTHON_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rosbridge_library[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"