summaryrefslogtreecommitdiff
path: root/dev-ros/robot_pose_ekf/robot_pose_ekf-1.15.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-25 08:07:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-25 08:07:03 +0000
commita1b20429e7e2ba1b44414459afd5a2b50788cd9c (patch)
treee721db30ecc3e534a03ab9b3115762959cc0c28c /dev-ros/robot_pose_ekf/robot_pose_ekf-1.15.0.ebuild
parentdbbd2ae5e62a232616ede4dae3ed69e15903940a (diff)
gentoo auto-resync : 25:01:2023 - 08:07:03
Diffstat (limited to 'dev-ros/robot_pose_ekf/robot_pose_ekf-1.15.0.ebuild')
-rw-r--r--dev-ros/robot_pose_ekf/robot_pose_ekf-1.15.0.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/dev-ros/robot_pose_ekf/robot_pose_ekf-1.15.0.ebuild b/dev-ros/robot_pose_ekf/robot_pose_ekf-1.15.0.ebuild
deleted file mode 100644
index af03ac6af239..000000000000
--- a/dev-ros/robot_pose_ekf/robot_pose_ekf-1.15.0.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-ROS_REPO_URI="https://github.com/ros-planning/robot_pose_ekf"
-KEYWORDS="~amd64 ~arm"
-CATKIN_HAS_MESSAGES=yes
-CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
-
-inherit ros-catkin
-
-DESCRIPTION="Estimate the 3D pose of a robot from pose measurements from various sources"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-ros/roscpp
- dev-ros/tf
- sci-libs/orocos-bfl
- dev-libs/boost:=
-"
-DEPEND="${RDEPEND}
- dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- test? (
- dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
- dev-cpp/gtest
- )
- virtual/pkgconfig"
-
-TEST_DATA="ekf_test2_indexed.bag zero_covariance_indexed.bag"
-
-SRC_URI="${SRC_URI} test? ( "
-for i in ${TEST_DATA}; do
- SRC_URI="${SRC_URI} http://download.ros.org/data/robot_pose_ekf/${i} -> ${P}-${i}"
-done
-SRC_URI="${SRC_URI} )"
-
-src_prepare() {
- ros-catkin_src_prepare
- if use test; then
- for i in ${TEST_DATA} ; do
- cp "${DISTDIR}/${P}-${i}" "${S}/${i}" || die
- done
- sed \
- -e "s#http://download.ros.org/data/robot_pose_ekf#file://${S}#" \
- -i CMakeLists.txt || die
- fi
-}
-
-src_test() {
- export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
- ros-catkin_src_test
-}