summaryrefslogtreecommitdiff
path: root/dev-ros/robot_pose_ekf/robot_pose_ekf-1.14.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-20 14:45:01 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-20 14:45:01 +0100
commit34dea8e38f88007799629d0a56b12dec480b1d21 (patch)
tree6790873994b58030360328cf5897d934b3b03d16 /dev-ros/robot_pose_ekf/robot_pose_ekf-1.14.5-r1.ebuild
parent7932d472a02d4c016ff7dff4b7a5479ab9d1883d (diff)
gentoo resync : 20.06.2021
Diffstat (limited to 'dev-ros/robot_pose_ekf/robot_pose_ekf-1.14.5-r1.ebuild')
-rw-r--r--dev-ros/robot_pose_ekf/robot_pose_ekf-1.14.5-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/robot_pose_ekf/robot_pose_ekf-1.14.5-r1.ebuild b/dev-ros/robot_pose_ekf/robot_pose_ekf-1.14.5-r1.ebuild
new file mode 100644
index 000000000000..59f91b30ba19
--- /dev/null
+++ b/dev-ros/robot_pose_ekf/robot_pose_ekf-1.14.5-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-planning/robot_pose_ekf"
+KEYWORDS="~amd64 ~arm"
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Estimate the 3D pose of a robot from pose measurements from various sources"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/tf
+ sci-libs/orocos-bfl
+ dev-libs/boost:=[threads(+)]
+"
+DEPEND="${RDEPEND}
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ test? (
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ dev-cpp/gtest
+ )
+ virtual/pkgconfig"